summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 12:00:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:35 +0200
commitbd86c0e743b6d3f2f5903e6a4ff4f1be976f19c8 (patch)
treeaaaa44d24b556e83e556b4ccc30ce0a4ecf29c2c
parent0b3ffaebaec33384f242c7fd580fc3a3e7e18c10 (diff)
gnu: Add texlive-citation-style-language.
* gnu/packages/tex.scm (texlive-citation-style-language): New variable.
-rw-r--r--gnu/packages/tex.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 65f384bd1d..b89db029ed 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6415,6 +6415,46 @@ Technology that follows given recommendations.")
to typeset Church Slavonic texts.")
(license license:expat)))
+(define-public texlive-citation-style-language
+ (package
+ (name "texlive-citation-style-language")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/citation-style-language/"
+ "doc/man/man1/citeproc-lua.1"
+ "doc/man/man1/citeproc-lua.man1.pdf"
+ "scripts/citation-style-language/"
+ "tex/latex/citation-style-language/")
+ (base32
+ "13342c9kq5zy9a6kag81xfa38dydmimhcnb11jx7d8il6g0pd46w")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "citeproc-lua.lua")))
+ (propagated-inputs
+ (list texlive-filehook
+ texlive-l3kernel
+ texlive-l3packages
+ texlive-lua-uca
+ texlive-lualibs
+ texlive-luatex
+ texlive-luaxml
+ texlive-url))
+ (home-page "https://ctan.org/pkg/citation-style-language")
+ (synopsis "Bibliography formatting with Citation Style Language")
+ (description
+ "The Citation Style Language (CSL) is an XML-based language that defines
+the formats of citations and bibliography. There are currently thousands of
+styles in CSL including the most widely used APA, Chicago, Vancouver, etc.
+The citation-style-language package is aimed to provide another reference
+formatting method for LaTeX that utilizes the CSL styles. It contains
+a citation processor implemented in pure Lua (@code{citeproc-lua}) which reads
+bibliographic metadata and performs sorting and formatting on both citations
+and bibliography according to the selected CSL style. A LaTeX package
+(@file{citation-style-language.sty}) is provided to communicate with the
+processor.")
+ (license (list license:expat license:cc-by-sa3.0))))
+
(define-public texlive-cjhebrew
(package
(name "texlive-cjhebrew")