summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:44:09 +0200
commitc036eea3482adc5fc8ece09672bb8d4daf13fd58 (patch)
treee7533f7879412c40b3ff08b27fc6862933bff406
parent851d60c89c47be533f8cbab80939010ea95f5eb2 (diff)
gnu: vdirsyncer: Move to pyproject-build-system and enable tests.
* gnu/packages/dav.scm (vdirsyncer): [build-system]: Move to pyproject-build-system. [arguments]<#:tests?>: Remove to enable tests. <#:test-flags>: Ignore test that require network connection. <#:phases>: Remove check phase replacement. Change-Id: Iafccfc65e3a847a0eecc26c179f435b9ec1fdfec Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/dav.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index ae03442374..b30b1ef5a5 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2022 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,6 +24,7 @@
(define-module (gnu packages dav)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix licenses)
@@ -124,20 +126,12 @@ efficient syncing
(sha256
(base32
"1fl21m10ghrpmkqa12g0qri99cxk9879pkb60jd4b4w2mgp8q1gx"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
- #:tests? #f ; the test suite is very flakey
+ #:test-flags '(list "-k" "not test_request_ssl")
#:phases
#~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (setenv "DETERMINISTIC_TESTS" "true")
- (setenv "DAV_SERVER" "radicale")
- (setenv "REMOTESTORAGE_SERVER" "skip")
- (if tests?
- (invoke "make" "test"))))
(add-after 'unpack 'patch-version-call
(lambda _
(substitute* "docs/conf.py"