summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:46:28 +0200
commitde78dcd2f34940d4322a61e4a479568c3b38673a (patch)
treec9716f1754076c87b4d9b0ba230dd2bdb77c5767
parent831591b5e61eea73e9058aef12c43bd5b733fc7e (diff)
gnu: python-pytest-runner: Improve package style.
* gnu/packages/check.scm (python-pytest-runner): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Remove check phase replacement. Update <#:tests?> refusal comment. [native-inputs]: Add python-pip, python-pypa-build, python-setuptools and python-wheel. Change-Id: Id36e7ed4a3cec6098f0877f48f3fbcbd8007f3c3 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/check.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 15d2910603..5708fa91ac 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1640,10 +1640,10 @@ Python's @code{random.seed}.")
(sha256
(base32
"11dnhxnjmh4nf1j8rnvx944ha3wg8ggrgrwdcx4c7d19xmi57n5l"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
- ;; FIXME: The test suite requires 'python-flake8' and 'python-black',
+ ;; FIXME: The test suite requires 'python-pytest-virtualenv',
;; but that introduces a circular dependency.
#:tests? #f
#:phases
@@ -1657,14 +1657,10 @@ Python's @code{random.seed}.")
(lambda _
(let ((whl (car (find-files "dist" "\\.whl$"))))
(invoke "pip" "--no-cache-dir" "--no-input"
- "install" "--no-deps" "--prefix" #$output whl))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%")))))))
+ "install" "--no-deps" "--prefix" #$output whl)))))))
(native-inputs
- (list python-pypa-build python-setuptools-scm python-wheel))
+ (list python-pip python-pypa-build python-pytest
+ python-setuptools python-setuptools-scm python-wheel))
(home-page "https://github.com/pytest-dev/pytest-runner")
(synopsis "Invoke py.test as a distutils command")
(description