summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-09 22:40:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-09 22:40:06 +0200
commitdfaa8ed2a5bec94debde44ea285761cf06bdaf38 (patch)
tree7836715b86a8b0cbf073ebddc6835f60891909b3
parentbd26278858b06261a6a847ee3866f9aae69b2984 (diff)
gnu: python-nbclient: Update to 0.10.0.
* gnu/packages/jupyter.scm (python-nbclient): Update to 0.10.0. [native-inputs]: Remove python-setuptools and python-wheel; add python-hatchling, python-flaky, python-pytest, python-pytest-asyncio, python-pytest-cov, python-testpath, and python-xmltodict. Change-Id: I15a87323456c6b4eaa8361972bcb6ae3686ec687
-rw-r--r--gnu/packages/jupyter.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 2c982b4c21..e231794836 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -715,14 +715,14 @@ Mathjax, the JavaScript display engine for mathematics.")
(define-public python-nbclient
(package
(name "python-nbclient")
- (version "0.6.6")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "nbclient" version))
(sha256
(base32
- "09whkb8ll1nfdn4h3k0shncgkfak4lglmiwn8wdni6nrc5wnmxqd"))))
+ "02dvb9ffpd237apyj4fw97a9371kv99lzny49624j7jkp9yingsb"))))
(build-system pyproject-build-system)
;; Tests require tools from nbconvert, which would introduces a cycle.
(arguments '(#:tests? #false))
@@ -730,7 +730,13 @@ Mathjax, the JavaScript display engine for mathematics.")
(list python-jupyter-client python-jupyter-core python-nbformat
python-traitlets))
(native-inputs
- (list python-setuptools python-wheel))
+ (list python-hatchling
+ python-flaky
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-cov
+ python-testpath
+ python-xmltodict))
(home-page "https://jupyter.org")
(synopsis "Client library for executing notebooks")
(description