summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-10 11:40:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-10 11:43:21 +0200
commite5eceb18dc609d22e5158e339c0a2c657bb46ee2 (patch)
tree8e1e00e906889a956169c7c170068b870f2a16e6
parentb1bb385be33e1587bc93b880dd43e4d1577a00fd (diff)
gnu: Add python-comm.
* gnu/packages/jupyter.scm (python-comm): New variable. Change-Id: I888125238a566b470d4f5f96c5cc178f41a7a4ff
-rw-r--r--gnu/packages/jupyter.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index e231794836..9a5e26fc93 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -52,6 +52,32 @@
#:use-module (gnu packages serialization)
#:use-module (gnu packages version-control))
+(define-public python-comm
+ (package
+ (name "python-comm")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipython/comm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18xsbpd8dgcfbc51xl59nlwaq7jnyzvgzjfj6psscv71894x4lg7"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-traitlets))
+ (native-inputs
+ (list python-hatchling
+ python-pytest))
+ (home-page "https://github.com/ipython/comm")
+ (synopsis "Jupyter Python Comm implementation")
+ (description
+ "Jupyter Python Comm provides a way to register a Kernel Comm
+implementation, as per the Jupyter kernel protocol. It also provides a base
+Comm implementation and a default CommManager that can be used.")
+ (license license:bsd-3)))
+
(define-public python-nbclassic
(package
(name "python-nbclassic")