summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 13:27:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:43 +0200
commitff5d2d0ed962c4fdae797a31985aebe7e06692e5 (patch)
tree22f642c3a06e2ad7517f0348bfe44ffc531dc2d6
parent98fc89f7d94c69baccae9fa072b639ca0211a6e1 (diff)
gnu: Add texlive-listbib.
* gnu/packages/tex.scm (texlive-listbib): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a9dce58b2..db500a9d75 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11808,6 +11808,28 @@ grammaticality judgments. The @code{ps-trees} package provides linguistic
trees.")
(license license:lppl)))
+(define-public texlive-listbib
+ (package
+ (name "texlive-listbib")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/listbib/" "doc/latex/listbib/"
+ "scripts/listbib/" "source/latex/listbib/"
+ "tex/latex/listbib/")
+ (base32
+ "1k4xwmv6lh1vaggimzmiqib8aai9dm0j586m0hds04485pvhv5ky")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "listbib")))
+ (home-page "https://ctan.org/pkg/listbib")
+ (synopsis "Lists contents of BibTeX files")
+ (description
+ "This package generates listings of bibliographic data bases in BibTeX
+format. Included is a @file{listbib.bst}, which is better suited for this
+purpose than the standard styles.")
+ (license license:gpl3+)))
+
(define-public texlive-lithuanian
(package
(name "texlive-lithuanian")