summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:50:36 +0200
commitffce4d7f17b768a922366e45713fea7ab604b172 (patch)
tree48840d8b92b96ccaf72781a066a66d7c8e581562
parent6f64f0d6e9ce0b07f8edb9a67678734da178f7e6 (diff)
gnu: python-cmd2: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-cmd2): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Remove check phase replacement. <#:test-flags>: Add field. Change-Id: I55b4134fb6caa4af1a4988934043487fa85f9b9b Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a10a45aba7..3ba765d94f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31711,18 +31711,10 @@ intended for validating data coming into Python as JSON, YAML, etc.")
(sha256
(base32
"0h1naik558qh48gx2iyy0a0khvw5fz0in69y84mbrhsm9nq7w3bm"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv" "-k"
- ;; These tests fail because no EDITOR is in PATH.
- "not test_find_editor_not_specified \
-and not test_transcript")
- (format #t "test suite not run~%")))))))
+ (list #:test-flags '(list "-k" "not test_find_editor_not_specified \
+and not test_transcript")))
(propagated-inputs
(list python-attrs python-colorama python-pyperclip python-wcwidth))
(native-inputs