summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-16 18:20:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-17 11:11:15 +0200
commit96f3c7504a68ee0df1f7f4a74616dc0f0a7d9016 (patch)
treebb58e268ef3d7e7269500ecda7ed1f3e6e328519
parentb2bc0ecb296ce41b22dfca7132a33dc164a4e572 (diff)
gnu: Add r-writexls.
* gnu/packages/cran.scm (r-writexls): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8c631bdccd..46b046c83b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12635,6 +12635,29 @@ documents.")
libxlsxwriter.")
(license license:bsd-2)))
+(define-public r-writexls
+ (package
+ (name "r-writexls")
+ (version "6.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "WriteXLS" version))
+ (sha256
+ (base32
+ "1dqr98kx930y6mcvb9b39xiwshhs250gkd2vw2v6iil34sl90jv4"))))
+ (properties `((upstream-name . "WriteXLS")))
+ (build-system r-build-system)
+ (inputs (list perl))
+ (home-page "https://github.com/marcschwartz/WriteXLS")
+ (synopsis "Create Excel 2003 (XLS) and Excel 2007 (XLSX) files")
+ (description
+ "This package provides a cross-platform Perl-based R function to create
+Excel 2003 (XLS) and Excel 2007 (XLSX) files from one or more data frames.
+Each data frame will be written to a separate named worksheet in the Excel
+spreadsheet. The worksheet name will be the name of the data frame it
+contains or can be specified by the user.")
+ (license license:gpl2+)))
+
(define-public r-biasedurn
(package
(name "r-biasedurn")