summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-17 11:15:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-17 11:15:58 +0300
commitb2bc0ecb296ce41b22dfca7132a33dc164a4e572 (patch)
tree41837ffdd375245caf6a6c97a67ae5e74e14f10e
parentbd0b398b67bf2fc95620b79258748b8f7eafc2c8 (diff)
gnu: python-outcome: Update to 1.2.0.
* gnu/packages/python-xyz.scm (python-outcome): Update to 1.2.0. [propagated-inputs]: Remove python-async-generator.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0147870b06..284f8019bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2015, 2016, 2017, 2019, 2022 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2017, 2020 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
@@ -24782,13 +24782,13 @@ make your work easier.")
(define-public python-outcome
(package
(name "python-outcome")
- (version "1.0.1")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "outcome" version))
(sha256
- (base32 "0vxn04vspmlkkyijjkjnsc46f93ki8g62hr7ag10zpd7ic324y7w"))))
+ (base32 "0wi6bmsfn73aw1hbpa1nhhshlx9k2vxcl7kp3z7h78sxwhyvv0kg"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -24800,7 +24800,7 @@ make your work easier.")
(native-inputs
(list python-pytest python-pytest-cov python-pytest-asyncio))
(propagated-inputs
- (list python-async-generator python-attrs))
+ (list python-attrs))
(home-page "https://github.com/python-trio/outcome")
(synopsis "Capture the outcome of Python function calls")
(description