summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-17 11:13:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-17 11:13:26 +0300
commitbd0b398b67bf2fc95620b79258748b8f7eafc2c8 (patch)
tree193718459bfe697393c5457e8c9e68236ca075b9
parent929995a542aa3e7dcc1b13e0a1f7822e61cb54a4 (diff)
gnu: python-jeepney: Update to 0.8.0.
* gnu/packages/python-crypto.scm (python-jeepney): Update to 0.8.0. [build-system]: Switch to pyproject-build-system. [native-inputs]: Add python-async-timeout, python-pytest-asyncio, python-flit-core. Remove python-tornado.
-rw-r--r--gnu/packages/python-crypto.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 4532d49c3c..f434c90c73 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1501,17 +1501,23 @@ certificates, signing and building trust bundles.")
(define-public python-jeepney
(package
(name "python-jeepney")
- (version "0.6.0")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jeepney" version))
(sha256
- (base32 "0mw6ch5s4czpmsiwqwhcidgk27858pl8vlvb7acrxjkm4ribcnbx"))))
- (build-system python-build-system)
+ (base32 "01jqrk7pn94i7bpmj834pjrw7id659gfag6wpbv04fcpap94izjy"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-testpath python-tornado python-trio python-pytest
- python-pytest-trio))
+ (list python-async-timeout
+ python-testpath
+ python-trio
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-trio
+ ;; For the build backend
+ python-flit-core))
(home-page "https://gitlab.com/takluyver/jeepney")
(synopsis "Low-level, pure Python DBus protocol wrapper")
(description