summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:18:51 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 10:41:58 +0200
commit0402806bff9d71f0e522a8f23aeed063395c9b26 (patch)
tree62cab592f0dd65dee50fb614d2fc8abf2f202703
parentaa18e500c818f73df656c637409105a36aa54f92 (diff)
gnu: perl6-json-class: Update to 0.0.18.
* gnu/packages/perl6.scm (perl6-json-class): Update to 0.0.18. [source]: Reindent. [propagated-inputs]: Move below native-inputs. [synopsis, description]: Fix minor stylistic issues. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/perl6.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 79c4b661e9..f18ac16300 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -384,30 +384,29 @@ deserializing JSON.")
(define-public perl6-json-class
(package
(name "perl6-json-class")
- (version "0.0.12")
+ (version "0.0.18")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jonathanstowe/JSON-Class")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1zyzajc57j3m8q0nr72h9pw4w2nx92rafywlvysgphc5q9sb8np2"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonathanstowe/JSON-Class")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0686qpcb6p5isjcsksrgsr1rh926cnhs6r091p5p3lh2fd575g1d"))))
(build-system rakudo-build-system)
- (propagated-inputs
- (list perl6-json-marshal perl6-json-unmarshal))
(native-inputs
(list perl6-json-fast))
+ (propagated-inputs
+ (list perl6-json-marshal perl6-json-unmarshal))
(home-page "https://github.com/jonathanstowe/JSON-Class")
- (synopsis "Provide simple serialisation/deserialisation of objects to/from JSON")
+ (synopsis "Provide simple serialization/deserialization of objects to/from JSON")
(description "This is a simple role that provides methods to instantiate a
-class from a JSON string that (hopefully,) represents it, and to serialise an
+class from a JSON string that (hopefully) represents it, and to serialize an
object of the class to a JSON string. The JSON created from an instance
should round trip to a new instance with the same values for the public
attributes. Private attributes (that is ones without accessors,) will be
-ignored for both serialisation and de-serialisation. The exact behaviour
+ignored for both serialization and deserialization. The exact behaviour
depends on that of @code{JSON::Marshal} and @code{JSON::Unmarshal}
respectively.")
(license license:artistic2.0)))