summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:19:39 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 10:41:59 +0200
commit0596f596ea215bd17d77d1f48ea2a2b0319c2784 (patch)
tree8adb646de54330832679144abb3b294810054b69
parent3eb5ffb90f5e75e6da94bf60bfffcbdf1e4c5b72 (diff)
gnu: Add perl6-format-lisp.
* gnu/packages/perl6.scm (perl6-format-lisp): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/perl6.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 3922860071..4f0fc1a5a7 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -304,6 +304,29 @@ regular expression engine for the virtual machine.")
and runs on top of several virtual machines.")
(license license:artistic2.0)))
+(define-public perl6-format-lisp
+ (let ((commit "1ae31e2a9366b287a83a9d451295fc9e3fb6d36f")
+ (revision "0"))
+ (package
+ (name "perl6-format-lisp")
+ (version (git-version "0.0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/raku-community-modules/Format-Lisp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rhkd11xdyw99vl6ickjin0x7nhlgkq3qhpf8zp9jky0k711gxmr"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/raku-community-modules/Format-Lisp")
+ (synopsis "Common Lisp's format call in Raku")
+ (description "This Raku module implements Common Lisp's @code{format}
+language.")
+ (license license:artistic2.0))))
+
(define-public perl6-grammar-debugger
;; Last commit was September 2017.
(let ((commit "0375008027c8caa216bd869476ce59ae09b2a702")