summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-10-15 22:47:32 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-11-03 15:11:30 +0100
commit622042110c30fbf28d88940758e8b444b985de4a (patch)
tree4aab8e77a5a815e3acec547586a3c5aed1280e80
parenteaf4441b620df4902bf91f1404aa6d8b006d8dbe (diff)
gnu: java-commons-compress: Update to 1.21.
* gnu/packages/java.scm (java-commons-compress): Update to 1.21. (java-osgi-annotation, java-osgi-core): Create pom file and install from it. * gnu/packages/maven.scm (java-surefire-parent-pom): Fix pom fixing.
-rw-r--r--gnu/packages/java.scm45
-rw-r--r--gnu/packages/maven.scm3
2 files changed, 23 insertions, 25 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 4de62a782c..da39d92d9b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6828,40 +6828,29 @@ programs.")
(define-public java-commons-compress
(package
(name "java-commons-compress")
- (version "1.13")
+ (version "1.21")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/commons/compress/source/"
"commons-compress-" version "-src.tar.gz"))
(sha256
(base32
- "1vjqvavrn0babffn1kciz6v52ibwq2vwhzlb95hazis3lgllnxc8"))))
+ "1rkpb6xcyly1wnbx4q6iq6p5hrr0h1d0ppb5r07psc75cbmizjry"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "commons-compress.jar"
+ #:source-dir "src/main/java"
+ #:tests? #f; requires java-mockito-3
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'delete-bad-tests
- (lambda _
- (with-directory-excursion "src/test/java/org/apache/commons/compress/"
- ;; FIXME: These tests really should not fail. Maybe they are
- ;; indicative of problems with our Java packaging work.
-
- ;; This test fails with a null pointer exception.
- (delete-file "archivers/sevenz/SevenZOutputFileTest.java")
- ;; This test fails to open test resources.
- (delete-file "archivers/zip/ExplodeSupportTest.java")
-
- ;; FIXME: This test adds a dependency on powermock, which is hard to
- ;; package at this point.
- ;; https://github.com/powermock/powermock
- (delete-file "archivers/sevenz/SevenZNativeHeapTest.java"))
- #t))
(replace 'install (install-from-pom "pom.xml")))))
(propagated-inputs
- (list java-xz apache-commons-parent-pom-41))
- (native-inputs
- (list java-junit java-mockito-1))
+ (list java-asm-3
+ java-brotli
+ java-osgi-core
+ java-xz
+ java-zstd
+ apache-commons-parent-pom-52))
(home-page "https://commons.apache.org/proper/commons-compress/")
(synopsis "Java library for working with compressed files")
(description "The Apache Commons Compress library defines an API for
@@ -6923,7 +6912,12 @@ Custom formats can be created using a fluent style API.")
(build-system ant-build-system)
(arguments
`(#:tests? #f ; no tests
- #:jar-name "osgi-annotation.jar"))
+ #:jar-name "osgi-annotation.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'create-pom
+ (generate-pom.xml "pom.xml" "osgi" "osgi-annotation" ,version))
+ (replace 'install (install-from-pom "pom.xml")))))
(home-page "https://www.osgi.org")
(synopsis "Annotation module of OSGi framework")
(description
@@ -6948,7 +6942,12 @@ components.")
(build-system ant-build-system)
(arguments
`(#:tests? #f ; no tests
- #:jar-name "osgi-core.jar"))
+ #:jar-name "osgi-core.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'create-pom
+ (generate-pom.xml "pom.xml" "org.osgi" "org.osgi.core" ,version))
+ (replace 'install (install-from-pom "pom.xml")))))
(inputs
(list java-osgi-annotation))
(home-page "https://www.osgi.org")
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index b7794c4e89..d3e5677669 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -3462,8 +3462,7 @@ internal to the SureFire Logger API. It is designed to have no dependency.")
(add-before 'install 'fix-pom-dependency-versions
(lambda _
(substitute* "pom.xml"
- (("1.11") ,(package-version java-commons-compress))
- (("1.13") ,(package-version java-commons-codec)))
+ (("1.11") ,(package-version java-commons-codec)))
(substitute* "pom.xml"
(("commonsLang3Version>.*")
(string-append