summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:19:19 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 10:41:58 +0200
commit834a1c9b8626f646aedfd894976e33780842b318 (patch)
treed0185dcb7818f4d0f45b58c41daab83dcf748450
parent442fbb6fddaa78a55e2bec1842eacbb89009274d (diff)
gnu: perl6-svg-plot: Perl -> Raku.
* gnu/packages/perl6.scm (perl6-svg-plot)[source]: Reindent. [synopsis, description]: Replace mentions of Perl with Raku. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/perl6.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 20f02e57be..8884449d08 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -664,28 +664,27 @@ identify an XML file as SVG.")
(license license:artistic2.0))))
(define-public perl6-svg-plot
- ;; Latest commit
+ ;; Latest commit.
(let ((commit "062570a78fd38c3c6baba29dfe2fbb8ca014f4de")
(revision "1"))
(package
(name "perl6-svg-plot")
(version (git-version "0.0.0" revision commit))
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/moritz/svg-plot")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "095ga5hbg92jnmczxvhk1hjz14yr334zyf8cph4w5w5frcza44my"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moritz/svg-plot")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "095ga5hbg92jnmczxvhk1hjz14yr334zyf8cph4w5w5frcza44my"))))
(build-system rakudo-build-system)
(propagated-inputs
(list perl6-svg))
(home-page "https://github.com/moritz/svg-plot")
- (synopsis "Perl 6 charting and plotting library that produces SVG output")
- (description "@code{SVG::Plot} is a simple 2D chart plotter for Perl 6.
+ (synopsis "Raku charting and plotting library that produces SVG output")
+ (description "@code{SVG::Plot} is a simple 2D chart plotter for Raku.
It currently supports bars, stacked bars, lines and points (both equally spaced
with optional labels, or xy plots).")
(license license:artistic2.0))))