summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-05-11 23:50:14 -0700
committerGuillaume Le Vaillant <glv@posteo.net>2023-05-14 10:19:39 +0200
commit930e6e3e7a1c5f83aedb49f6fa0ebb0e0bdeeef3 (patch)
treeda58f22473f281b566320ad3c5961ea18e266040
parent56f52639bb93a4aefe11a794a64a92987125b8b4 (diff)
gnu: mesa-opencl: Remove reference to patch.
Fixes <https://bugs.gnu.org/63456>. * gnu/packages/patches/mesa-opencl-all-targets.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/gl.scm (mesa-opencl)[source]: Remove patch application. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gl.scm4
-rw-r--r--gnu/packages/patches/mesa-opencl-all-targets.patch25
3 files changed, 1 insertions, 29 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index d31b40f3bf..012ce84d2d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1562,7 +1562,6 @@ dist_patch_DATA = \
%D%/packages/patches/memtest86+-build-reproducibly.patch \
%D%/packages/patches/mercurial-hg-extension-path.patch \
%D%/packages/patches/mercurial-openssl-compat.patch \
- %D%/packages/patches/mesa-opencl-all-targets.patch \
%D%/packages/patches/mhash-keygen-test-segfault.patch \
%D%/packages/patches/mia-fix-boost-headers.patch \
%D%/packages/patches/mia-vtk9.patch \
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index c89e434ed6..9885bde712 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -530,9 +530,7 @@ from software emulation to complete hardware acceleration for modern GPUs.")
(package/inherit mesa
(name "mesa-opencl")
(source (origin
- (inherit (package-source mesa))
- (patches (cons (search-patch "mesa-opencl-all-targets.patch")
- (origin-patches (package-source mesa))))))
+ (inherit (package-source mesa))))
(arguments
(substitute-keyword-arguments (package-arguments mesa)
((#:configure-flags flags)
diff --git a/gnu/packages/patches/mesa-opencl-all-targets.patch b/gnu/packages/patches/mesa-opencl-all-targets.patch
deleted file mode 100644
index 99d4abcea4..0000000000
--- a/gnu/packages/patches/mesa-opencl-all-targets.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-This patch restores LLVM targets needed for OpenCL, *reverting* this
-upstream commit:
-
- From 80817b6e344258ac9b955f824ebf9019a0fc1610 Mon Sep 17 00:00:00 2001
- From: Jesse Natalie <jenatali@microsoft.com>
- Date: Wed, 18 Nov 2020 18:30:30 -0800
- Subject: [PATCH] meson: Adjust Clover's required LLVM modules
-
-diff --git a/meson.build b/meson.build
-index 6d1607c35a3..f828eb80faa 100644
---- b/meson.build
-+++ a/meson.build
-@@ -1479,10 +1479,9 @@
- endif
- if with_gallium_opencl
- llvm_modules += [
-- 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
-- 'lto', 'option', 'objcarcopts', 'profiledata'
-+ 'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
-+ 'lto', 'option', 'objcarcopts', 'profiledata',
- ]
-- llvm_optional_modules += ['frontendopenmp']
- endif
- if with_microsoft_clc
- llvm_modules += ['target', 'linker', 'irreader', 'option', 'libdriver']