summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordan <i@dan.games>2024-03-02 21:19:59 +0800
committerAndrew Tropin <andrew@trop.in>2024-03-04 17:35:07 +0300
commit9321cf7f51eb6dc3fe49d4302eed4e47a52284e2 (patch)
tree5e59309189936f74f9db60eb30827103f15efda4
parent8850782392d4e58384d4c4da36a4f0bd5c8abdb1 (diff)
gnu: Add emacs-citar-denote.
* gnu/packages/emacs-xyz.scm (emacs-citar-denote): New variable. Change-Id: Ib728e5f005f2c6cd84864bb0ecc11c8ed40ac24b Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a93165404e..f858597ea7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -137,6 +137,7 @@
;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
+;;; Copyright © 2024 dan <i@dan.games>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23841,6 +23842,29 @@ Citar note support:
@end itemize")
(license license:gpl3+)))
+(define-public emacs-citar-denote
+ (package
+ (name "emacs-citar-denote")
+ (version "2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pprevos/citar-denote")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0g476awbrdws7k7smk1qasz15df20zilx3wqbi3wj0i1q2dbsi8z"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-citar emacs-denote))
+ (home-page "https://github.com/pprevos/citar-denote")
+ (synopsis "Emacs package to create and retrieve bibliography notes with
+Citar and Denote")
+ (description
+ "@code{citar-denote} is a minor-mode integrating the Emacs Citar and
+Denote packages to enable create managing bibliographic notes and citations.")
+ (license license:gpl3+)))
+
(define-public emacs-helm-bibtex
(let ((commit "8ebf50d5bd368082d0b7ab79d26a52f372cdef98")
(revision "1"))