summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2020-09-13 15:45:54 +1000
committerLudovic Courtès <ludo@gnu.org>2021-04-22 14:04:27 +0200
commitb2b799e2d8330af934f48bf66afb5114addb4dd7 (patch)
tree8863ff1aa826ed98fcf237ff1279a6f6c445705a
parentd11574736207c69e40a5ee422e7b0465629a37cd (diff)
utils: Rename 'wrapper?' to 'wrapped-program?'.
* guix/build/utils.scm (wrap-program): The wrapper? procedure is incorrectly named as it actually checks to see if prog is the original program that was moved, not the wrapper. * guix/build/python-build-system: (wrap): Use renamed wrapped-program?. * gnu/packages/ebook.scm (calibre)[arguments]: Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ebook.scm2
-rw-r--r--guix/build/python-build-system.scm2
-rw-r--r--guix/build/utils.scm6
3 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 4731c0fa80..22a4b87e60 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -324,7 +324,7 @@ sip-include-dirs = [\"" pyqt "/share/sip" "\"]")))
;; rather than create ..calibre-real-real-s. For more
;; information see: https://issues.guix.gnu.org/43249.
(find-files "." (lambda (file stat)
- (not (wrapper? file)))))))
+ (not (wrapped-program? file)))))))
#t)))))
(home-page "https://calibre-ebook.com/")
(synopsis "E-book library management software")
diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 8ade1d5911..5b1339d14c 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -225,7 +225,7 @@ running checks after installing the package."
(define (list-of-files dir)
(find-files dir (lambda (file stat)
(and (eq? 'regular (stat:type stat))
- (not (wrapper? file))))))
+ (not (wrapped-program? file))))))
(define bindirs
(append-map (match-lambda
diff --git a/guix/build/utils.scm b/guix/build/utils.scm
index 6c37021673..a15beac114 100644
--- a/guix/build/utils.scm
+++ b/guix/build/utils.scm
@@ -96,7 +96,7 @@
patch-/usr/bin/file
fold-port-matches
remove-store-references
- wrapper?
+ wrapped-program?
wrap-program
wrap-script
@@ -1227,8 +1227,8 @@ known as `nuke-refs' in Nixpkgs."
(program wrap-error-program)
(type wrap-error-type))
-(define (wrapper? prog)
- "Return #t if PROG is a wrapper as produced by 'wrap-program'."
+(define (wrapped-program? prog)
+ "Return #t if PROG is a program that was moved and wrapped by 'wrap-program'."
(and (file-exists? prog)
(let ((base (basename prog)))
(and (string-prefix? "." base)