summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 20:08:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 20:15:56 -0400
commitb736af1824acb941919ee671ff5a8a67fa735406 (patch)
tree6026b4bc72a380f8209a6740aaabb2eef9fffd7d
parentf7a12f9224fc03eae4a49c007912b5f0c4f2f296 (diff)
gnu: catch-framework2: Rename variable to catch2.
Automated with: git grep -l catch-framework2 | xargs sed 's/catch-framework2/catch2/g' -i
-rw-r--r--gnu/packages/audio.scm2
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/check.scm4
-rw-r--r--gnu/packages/chemistry.scm2
-rw-r--r--gnu/packages/cpp.scm4
-rw-r--r--gnu/packages/enchant.scm2
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/geo.scm2
-rw-r--r--gnu/packages/irods.scm2
-rw-r--r--gnu/packages/networking.scm4
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/security-token.scm4
-rw-r--r--gnu/packages/simulation.scm2
-rw-r--r--gnu/packages/telegram.scm2
-rw-r--r--gnu/packages/xdisorg.scm2
15 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 663123e638..fd27c1cc71 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3615,7 +3615,7 @@ stretching and pitch scaling of audio. This package contains the library.")
(base32 "0nvhdzy0m3bchk3dpnspv2f518p2v9fjcrv36z1sva1pv9a2g35w"))))
(build-system cmake-build-system)
(native-inputs
- (list catch-framework2))
+ (list catch2))
(inputs
(list fftw))
(home-page "https://mixxxdj.github.io/libkeyfinder/")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f9904a0f56..4e9de568a0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3792,7 +3792,7 @@ comment or quality sections.")
(inputs
(list gsl openblas zlib))
(native-inputs
- `(("catch" ,catch-framework2-1)
+ `(("catch" ,catch2-1)
("perl" ,perl)
("shunit2" ,shunit2)
("which" ,which)))
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 75ae120d77..797fe71277 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -440,7 +440,7 @@ PyUnit and others.")
multi-paradigm automated test framework for C++ and Objective-C.")
(license license:boost1.0)))
-(define-public catch-framework2-1
+(define-public catch2-1
(package
(name "catch2")
(version "1.12.2")
@@ -469,7 +469,7 @@ multi-paradigm automated test framework for C++ and Objective-C.")
a multi-paradigm automated test framework for C++ and Objective-C.")
(license license:boost1.0)))
-(define-public catch-framework2
+(define-public catch2
(package
(name "catch2")
(version "2.13.8")
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 735d599d2d..c517610fe8 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -559,7 +559,7 @@ symmetries written in C. Spglib can be used to:
glm
netcdf))
(native-inputs
- (list catch-framework2 python-setuptools))
+ (list catch2 python-setuptools))
(home-page "https://pymol.org")
(synopsis "Molecular visualization system")
(description "PyMOL is a capable molecular viewer and renderer. It can be
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 6289c9520f..d03e0bc7e1 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -531,7 +531,7 @@ functions, class methods, and stl containers.
(modules '((guix build utils)))
(snippet '(delete-file-recursively "./test/thirdparty"))))
(inputs
- (list catch-framework2-1))
+ (list catch2-1))
(build-system cmake-build-system)
(arguments
'(#:phases
@@ -1264,7 +1264,7 @@ services including database, analytic, and machine learning technologies.")
(lambda _
(invoke "./tests"))))))
(native-inputs
- (list catch-framework2))
+ (list catch2))
(synopsis "C++11/14/17 std::expected with functional-style extensions")
(description "@code{std::expected} is proposed as the preferred way to
represent objects which will either have an expected value, or an unexpected
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index 4b31c3131b..1f82b2447e 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -58,7 +58,7 @@
(base32 "0wbb6dwmzlsyy224y0liis0azgzwbjdvcyzc31pw1aw6vbp36na6"))))
(build-system cmake-build-system)
(native-inputs
- (list catch-framework2
+ (list catch2
git-minimal
perl
;;FIX-ME: Building with ronn fails.
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 673ea8023b..5c84b9ede0 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3218,7 +3218,7 @@ perform various useful functions such as:
;; with all of these.
(inputs
`(("boost" ,boost)
- ("catch2" ,catch-framework2)
+ ("catch2" ,catch2)
("cgal" ,cgal)
("eigen" ,eigen)
("embree" ,embree)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7fe8372f87..c739388320 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -820,7 +820,7 @@ street bearings/orientations, and speed/travel time.")
(("TEST_CASE\\(\"ogr\"" all)
(string-append all ", \"[!shouldfail]\""))))))))
(native-inputs
- (list catch-framework2
+ (list catch2
pkg-config
postgresql))
(inputs
diff --git a/gnu/packages/irods.scm b/gnu/packages/irods.scm
index e9ac0d5297..58ef3bf474 100644
--- a/gnu/packages/irods.scm
+++ b/gnu/packages/irods.scm
@@ -154,7 +154,7 @@
("unixodbc" ,unixodbc)
("zeromq" ,zeromq)))
(native-inputs
- `(("catch2" ,catch-framework2)
+ `(("catch2" ,catch2)
("clang" ,clang-toolchain-6)
("clang-runtime" ,clang-runtime-6)
("libcxx+libcxxabi" ,libcxx+libcxxabi-6)))
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8aef0d19ee..8a9d698691 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1378,7 +1378,7 @@ between different versions of ØMQ.")
(native-inputs
(list pkg-config))
(inputs
- (list catch-framework2 zeromq))
+ (list catch2 zeromq))
(home-page "https://zeromq.org")
(synopsis "C++ bindings for the ØMQ messaging library")
(description
@@ -3603,7 +3603,7 @@ communication over HTTP.")
(build-system cmake-build-system)
(inputs ; TODO: Need to force-keep references on some inputs, e.g. boost.
(list zlib
- catch-framework2
+ catch2
openssl
boost
pcre
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9edfb0babb..e22d9dc87e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22305,7 +22305,7 @@ user-space file systems in Python.")
;; The following dependencies are used for tests.
("python-pytest" ,python-pytest)
- ("catch" ,catch-framework2-1)
+ ("catch" ,catch2-1)
("eigen" ,eigen)))
(arguments
`(#:configure-flags
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 6e94bfa534..447a7a582d 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -739,7 +739,7 @@ an unprivileged user.")
(arguments
;; These tests do not require any device to be connected
'(#:configure-flags (list "-DCOMPILE_OFFLINE_TESTS=ON")))
- (native-inputs (list catch-framework2 doxygen graphviz pkg-config))
+ (native-inputs (list catch2 doxygen graphviz pkg-config))
(inputs (list hidapi libusb))
(home-page "https://github.com/Nitrokey/libnitrokey")
(synopsis "Communication library for Nitrokey")
@@ -763,7 +763,7 @@ an unprivileged user.")
(arguments
'(#:configure-flags (list "-DBUILD_TESTING=on")))
(native-inputs (list pkg-config qttools-5))
- (inputs (list catch-framework2))
+ (inputs (list catch2))
(home-page "https://github.com/tplgy/cppcodec")
(synopsis "Header library to encode/decode base64, base64url, etc.")
(description "This package provides library to encode/decode base64,
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index b1bbb7f996..39b5620822 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -465,7 +465,7 @@ FFC is part of the FEniCS Project.")
("sundials" ,sundials-openmpi)
("zlib" ,zlib)))
(native-inputs
- `(("catch" ,catch-framework2-1)
+ `(("catch" ,catch2-1)
("pkg-config" ,pkg-config)))
(propagated-inputs
`(("ffc" ,python-fenics-ffc)
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 4976acbc0c..1a22d230d2 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -387,7 +387,7 @@ Telegram project, for its use in telegram desktop client.")
(inputs
`(("alsa" ,alsa-lib)
("c++-gsl" ,c++-gsl)
- ("catch" ,catch-framework2)
+ ("catch" ,catch2)
("codegen-source"
,(origin
(method git-fetch)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c017085353..9908f29191 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2893,7 +2893,7 @@ create layout indicator widgets.")
"1gxpgifzy0hnpd0ymw3r32amzr32z3bgb90ldjzl438p6h1q0i26"))))
(build-system cmake-build-system)
(native-inputs
- (list catch-framework2))
+ (list catch2))
(arguments
`(#:configure-flags '("-DWITH_GIT_CATCH=off")
#:phases