summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSuhail Singh <suhailsingh247@gmail.com>2024-03-05 00:45:19 -0500
committerEfraim Flashner <efraim@flashner.co.il>2024-03-05 10:14:01 +0200
commitb7f0aad907d6c33c4ccb137190b7a6b710a7112b (patch)
tree509db3f61777cbdaa5416053098a96a1ad75b874
parented84b7fe37f55a820121955785b722b8eca9b057 (diff)
gnu: Add emacs-lsp-booster.
* gnu/packages/rust-apps.scm (emacs-lsp-booster): New variable. Change-Id: If89f9941662ed01ddec578b220f69e6370775103 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/rust-apps.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 9e5c7d391f..7313cdef77 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
+;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -71,6 +72,7 @@
#:use-module (gnu packages crates-windows)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages emacs)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages haskell-xyz)
@@ -502,6 +504,43 @@ Features include:
@end enumerate\n")
(license license:gpl3)))
+(define-public emacs-lsp-booster
+ (package
+ (name "emacs-lsp-booster")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/blahgeek/emacs-lsp-booster")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xx32ms3mpi1clxf74mx7nanj0iw9qkmhi0a53fx8fkz0jw2fq8f"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list
+ #:cargo-inputs `(("rust-anyhow" ,rust-anyhow-1)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-clap-verbosity-flag" ,rust-clap-verbosity-flag-2)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-env-logger" ,rust-env-logger-0.10))
+ #:cargo-development-inputs `(("rust-emacs" ,rust-emacs-0.18)
+ ("rust-tempfile" ,rust-tempfile-3))
+ #:install-source? #f))
+ (native-inputs (list emacs)) ; Not emacs-minimal
+ (home-page "https://github.com/blahgeek/emacs-lsp-booster")
+ (synopsis "Emacs LSP performance booster")
+ (description
+ "@code{emacs-lsp-booster} improves the performance of @code{lsp-mode} and
+@code{eglot} Emacs packages using a wrapper executable. See the home-page for
+configuration instructions.")
+ (license license:expat)))
+
(define-public eza
(package
(name "eza")