summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-04 11:55:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-03-05 08:54:13 +0200
commitcd042f3a8efe85754a35979fadb392157ec12367 (patch)
tree8472a75ad6ca37ad44a445c70870576177223839
parent3da49b1472919a62df1fe399638f23a246aa325d (diff)
gnu: Remove libtommath-1.1.
* gnu/packages/multiprecision.scm (libtommath-1.1): Delete variable. * gnu/packages/patches/libtommath-fix-linkage.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I3a2bb697cbb72716756c24643920008e919889b5
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/multiprecision.scm25
-rw-r--r--gnu/packages/patches/libtommath-fix-linkage.patch55
3 files changed, 0 insertions, 81 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 67a0eab466..5e7fbf3545 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1608,7 +1608,6 @@ dist_patch_DATA = \
%D%/packages/patches/libtiff-CVE-2022-34526.patch \
%D%/packages/patches/libtirpc-CVE-2021-46828.patch \
%D%/packages/patches/libtirpc-hurd.patch \
- %D%/packages/patches/libtommath-fix-linkage.patch \
%D%/packages/patches/libtommath-integer-overflow.patch \
%D%/packages/patches/libtool-grep-compat.patch \
%D%/packages/patches/libtool-skip-tests2.patch \
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index a81b2771ab..18a269ddc7 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -505,28 +505,3 @@ integer library written entirely in C. It's designed to provide an API that is
simple to work with that provides fairly efficient routines that build out of
the box without configuration.")
(license unlicense)))
-
-(define-public libtommath-1.1
- (package
- (inherit libtommath)
- (version "1.1.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/libtom/libtommath/releases/"
- "download/v" version "/ltm-" version ".tar.xz"))
- (sha256
- (base32
- "1bbyagqzfdbg37k1n08nsqzdf44z8zsnjjinqbsyj7rxg246qilh"))
- (patches (search-patches "libtommath-fix-linkage.patch"))))
- (arguments
- (substitute-keyword-arguments (package-arguments libtommath)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'patch-coreutils-call
- (lambda _
- ;; Don't pull in coreutils.
- (substitute* "makefile_include.mk"
- (("arch") "uname -m"))
- #t))))
- ((#:test-target _) "test_standalone")))))
diff --git a/gnu/packages/patches/libtommath-fix-linkage.patch b/gnu/packages/patches/libtommath-fix-linkage.patch
deleted file mode 100644
index 1a9d46eb7c..0000000000
--- a/gnu/packages/patches/libtommath-fix-linkage.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-https://github.com/libtom/libtommath/commit/93dea3a4162527346cd8856bfda6f17ffe98ab04.patch
-
-From 93dea3a4162527346cd8856bfda6f17ffe98ab04 Mon Sep 17 00:00:00 2001
-From: Steffen Jaeckel <s@jaeckel.eu>
-Date: Thu, 31 Jan 2019 14:12:03 +0100
-Subject: [PATCH] makefile.shared: fix compilation and linkage
-
----
- makefile.shared | 15 ++++++++-------
- 1 file changed, 8 insertions(+), 7 deletions(-)
-
-diff --git a/makefile.shared b/makefile.shared
-index 3955f830..870b18d1 100644
---- a/makefile.shared
-+++ b/makefile.shared
-@@ -18,6 +18,7 @@ ifndef LIBTOOL
- endif
- endif
- LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC)
-+LTLINK = $(LIBTOOL) --mode=link --tag=CC $(CC)
-
- LCOV_ARGS=--directory .libs --directory .
-
-@@ -59,7 +60,7 @@ objs: $(OBJECTS)
- LOBJECTS = $(OBJECTS:.o=.lo)
-
- $(LIBNAME): $(OBJECTS)
-- $(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
-+ $(LTLINK) $(LDFLAGS) $(LOBJECTS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_SO) $(LIBTOOLFLAGS)
-
- install: $(LIBNAME)
- install -d $(DESTDIR)$(LIBPATH)
-@@ -76,16 +77,16 @@ uninstall:
- rm $(DESTDIR)$(LIBPATH)/pkgconfig/libtommath.pc
-
- test: $(LIBNAME) demo/demo.o
-- $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
-- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
-+ $(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
-+ $(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
-
- test_standalone: $(LIBNAME) demo/demo.o
-- $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
-- $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
-+ $(LTCOMPILE) $(CFLAGS) -c demo/demo.c -o demo/demo.o
-+ $(LTLINK) $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
-
- .PHONY: mtest
- mtest:
-- cd mtest ; $(CC) $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
-+ cd mtest ; $(CC) $(CFLAGS) -O0 mtest.c $(LDFLAGS) -o mtest
-
- timing: $(LIBNAME) demo/timing.c
-- $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing
-+ $(LTLINK) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o timing