summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 01:17:36 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:29 +0300
commit0f4d93903a73c1d32d6e05f4d4dc9d426b3ed248 (patch)
tree01c57f13b229afdc293ee34468e227758509c1bf
parent98418c810756f5990f7838b3e56961701a44cae4 (diff)
gnu: Add perl-regexp-pattern.
* gnu/packages/perl.scm (perl-regexp-pattern): New public variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e27f701cd4..bcc65f0d5e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8894,3 +8894,25 @@ to open the source file it is called from, and does so directly either by
lookup in %INC or by assuming it is $0 if the caller is @code{main}
(or it can't find %INC{caller()}).")
(license artistic2.0)))
+
+(define-public perl-regexp-pattern
+ (package
+ (name "perl-regexp-pattern")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PE/PERLANCAR/Regexp-Pattern-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0rwpl6dxd1yl2ng3d4jdy68jz3mggmdl35rphrw1x619sm1aa876"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)))
+ (home-page "http://search.cpan.org/dist/Regexp-Pattern/")
+ (synopsis "Collection of regexp patterns")
+ (description "Regexp::Pattern is a convention for organizing reusable
+regexp patterns in modules.")
+ (license (package-license perl))))