summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author( via Guix-patches via <guix-patches@gnu.org>2022-10-17 17:47:02 +0100
committerAndrew Tropin <andrew@trop.in>2022-11-10 16:52:55 +0400
commit2c9b4c573b6fd24ed350f19e1b0ea0b1c0fbe932 (patch)
treea6af49f13e911bd5104f86e0b3bc83022c2345e1
parent0760a8511d512ebac388eda0b9e18fd7451ca4b3 (diff)
gnu: mako: Patch makoctl to refer directly to binaries.
* gnu/packages/wm.scm (mako)[arguments]<#:phases>{'patch-makoctl}: New phase. [inputs]: Add jq. Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/wm.scm36
1 files changed, 26 insertions, 10 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 54e1c9c016..e765d28f53 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2022 Elais Player <elais@fastmail.com>
;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1807,17 +1808,32 @@ core/thread.")
(package
(name "mako")
(version "1.7.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emersion/mako")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0vpar1a7zafkd2plmyaackgba6fyg35s9zzyxmj8j7v2q5zxirgz"))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/mako")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vpar1a7zafkd2plmyaackgba6fyg35s9zzyxmj8j7v2q5zxirgz"))))
(build-system meson-build-system)
- (inputs (list basu cairo gdk-pixbuf pango wayland))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-makoctl
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "makoctl"
+ (("^BUSCTL=.*$")
+ (string-append
+ "BUSCTL="
+ (search-input-file inputs "bin/basuctl")
+ "\n"))
+ (("jq ")
+ (string-append
+ (search-input-file inputs "bin/jq")
+ " "))))))))
+ (inputs (list basu cairo gdk-pixbuf jq pango wayland))
(native-inputs (list pkg-config scdoc wayland-protocols))
(home-page "https://wayland.emersion.fr/mako")
(synopsis "Lightweight Wayland notification daemon")