summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-11-18 15:00:27 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-18 15:00:27 +0100
commit383b0f05904c5dac8238eeff96ca16873d9c5984 (patch)
treef9c956657dc1e4396a47ed8d3214328745471d5c
parent8cbd51d2d53cf8aa3794c7916750c6146eff1e5d (diff)
gnu: libarcus: Fix compatibility with newer protobuf.
* gnu/packages/engineering.scm (libarcus)[arguments]: Add 'fix-protobuf-compatibility' phase.
-rw-r--r--gnu/packages/engineering.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index b6a881d03b..21569b07c9 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3431,6 +3431,11 @@ BOM creation and has a lot of extra features.")
#:configure-flags '("-DBUILD_EXAMPLES=OFF")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-protobuf-compatibility
+ (lambda _
+ (substitute* "src/Socket_p.h"
+ (("stream\\.SetTotalBytesLimit\\(message_size_maximum,.*\\);")
+ "stream.SetTotalBytesLimit(message_size_maximum);"))))
(add-before 'configure 'fix-python-sitearch
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "cmake/FindSIP.cmake"