summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-19 17:19:56 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-08-22 21:29:21 +0200
commit4dfdd822102690b5687acf28365ab707b68d9476 (patch)
tree30bcfdf7c1d1e1acd987b7243e8a92019b8a757f
parent5898b2e8a3dbf7797e83b39a2783c5b543015725 (diff)
gnu: guix: Disable some tests on the Hurd.
* gnu/packages/package-management.scm (guix)[arguments]: When building on the Hurd, add phase disable-tests/hurd.
-rw-r--r--gnu/packages/package-management.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 8b42e911e2..5bc10e16f9 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -263,6 +263,46 @@ $(prefix)/etc/openrc\n")))
(substitute* "tests/gexp.scm"
(("2\\.0") "3.0")))))
'())
+ ,@(if (system-hurd?)
+ `((add-after 'unpack 'disable-tests/hurd
+ (lambda _
+ (substitute* "Makefile.am"
+ (("tests/derivations.scm") "")
+ (("tests/grafts.scm") "")
+ (("tests/graph.scm") "")
+ (("tests/lint.scm") "")
+ (("tests/nar.scm") "")
+ (("tests/offload.scm") "")
+ (("tests/pack.scm") "")
+ (("tests/packages.scm") "")
+ (("tests/processes.scm") "")
+ (("tests/publish.scm") "")
+ (("tests/pypi.scm") "")
+ (("tests/size.scm") "")
+ (("tests/store.scm") "")
+ (("tests/substitute.scm") "")
+ (("tests/syscalls.scm") "")
+ (("tests/union.scm") "")
+ (("tests/guix-build.sh") "")
+ (("tests/guix-build-branch.sh") "")
+ (("tests/guix-hash.sh") "")
+ (("tests/guix-locate.sh") "")
+ (("tests/guix-pack.sh") "")
+ (("tests/guix-pack-relocatable.sh") "")
+ (("tests/guix-package-aliases.sh") "")
+ (("tests/guix-package-net.sh") "")
+ (("tests/guix-home.sh") "")
+ (("tests/guix-archive.sh") "")
+ (("tests/guix-environment.sh") "")
+ (("tests/guix-package.sh") "")
+ (("tests/guix-refresh.sh") "")
+ (("tests/guix-shell.sh") "")
+ (("tests/guix-shell-export-manifest.sh") "")
+ (("tests/guix-system.sh") "")
+ (("tests/guix-graph.sh") "")
+ (("tests/guix-gc.sh") "")
+ (("tests/guix-daemon.sh") "")))))
+ '())
(add-before 'build 'use-host-compressors
(lambda* (#:key inputs target #:allow-other-keys)
(when target