summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <me@jeandudey.tech>2022-08-10 12:06:13 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-04-01 10:30:03 +0300
commit73c2eb262b6e1673983a89aa52f2ca3334d9ffe8 (patch)
tree92ba37500d7592bac7c6a0399288c8ecbb11c54f
parent23ae54b39cd5bc281346570f8a75b0e51942d5b2 (diff)
gnu: rust-anymap-0.12: Allow build.
* gnu/packages/crates-io.scm (rust-anymap-0.12)[arguments]: Remove `#:skip-build? #t'. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I643ad8a8a8b5fcb805e9ee9a1f648fd47792906b
-rw-r--r--gnu/packages/crates-io.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e7144dc25d..524f27abc2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2123,17 +2123,14 @@ writing colored text to a terminal.")
(origin
(method url-fetch)
(uri (crate-uri "anymap" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "0i23vv38i22aazp5z2hz0a44b943b6w5121kwwnpq1brpm1l559k"))))
+ (base32 "0i23vv38i22aazp5z2hz0a44b943b6w5121kwwnpq1brpm1l559k"))))
(build-system cargo-build-system)
- (arguments `(#:skip-build? #t))
- (home-page
- "https://github.com/chris-morgan/anymap")
- (synopsis
- "Safe and convenient store for one value of each type")
+ (arguments
+ `(#:tests? #f)) ; cannot transmute between types of different sizes
+ (home-page "https://github.com/chris-morgan/anymap")
+ (synopsis "Safe and convenient store for one value of each type")
(description
"This package provides a safe and convenient store for one value of each
type.")