summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-01 13:27:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-01 13:27:36 +0300
commit8a2b865fca3dd30bc11dbc929b30f82849d5d331 (patch)
tree84bae0443fb79dac56325e78ca9657721109511c
parent3cc96b640862691c46e64d1178c461a6cb8638e1 (diff)
gnu: Add rust-redox-syscall-0.5.
* gnu/packages/crates-io.scm (rust-redox-syscall-0.5): New variable. (rust-redox-syscall-0.4): Inherit from rust-redox-syscall-0.5. Change-Id: I8a67a8ad9740cde210eb3a39e31f0986cfdc38ba
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 23 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index be992a42ca..b218885de5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -60771,22 +60771,22 @@ using tokio's @code{RwLock}")
owned memory.")
(license license:expat)))
-(define-public rust-redox-syscall-0.4
+(define-public rust-redox-syscall-0.5
(package
(name "rust-redox-syscall")
- (version "0.4.1")
+ (version "0.5.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "redox_syscall" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1aiifyz5dnybfvkk4cdab9p2kmphag1yad6iknc7aszlxxldf8j7"))))
+ (base32 "0zja6y3av9z50gg1hh0vsc053941wng21r43whhk8mfb9n4m5426"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #f ; could not find `CloneFlags` in the crate root
+ `(#:tests? #f ; Functions not implemented on Linux.
#:cargo-inputs
- (("rust-bitflags" ,rust-bitflags-1)
+ (("rust-bitflags" ,rust-bitflags-2)
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))
(home-page "https://gitlab.redox-os.org/redox-os/syscall")
(synopsis "Rust library to access raw Redox system calls")
@@ -60794,6 +60794,24 @@ owned memory.")
"This package provides a Rust library to access raw Redox system calls.")
(license license:expat)))
+(define-public rust-redox-syscall-0.4
+ (package
+ (inherit rust-redox-syscall-0.5)
+ (name "rust-redox-syscall")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "redox_syscall" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1aiifyz5dnybfvkk4cdab9p2kmphag1yad6iknc7aszlxxldf8j7"))))
+ (arguments
+ `(#:tests? #f ; could not find `CloneFlags` in the crate root
+ #:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))))
+
(define-public rust-redox-syscall-0.3
(package
(inherit rust-redox-syscall-0.4)