summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-01 09:40:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-01 10:21:32 +0300
commitb69eb779056377923138750d0275171e119928f5 (patch)
tree72271d7e2ffd529145d434c175dfb4f51b4ed2c1
parent7c18e929d81d6a9580330053c44cc2764cfa840f (diff)
gnu: python-pyopenssl: Update to 24.1.0.
* gnu/packages/python-crypto.scm (python-pyopenssl): Update to 24.1.0. [arguments]: Adjust custom 'check phase to disable fewer tests and update faketime. [native-inputs]: Add python-pytest-rerunfailures. Remove python-pretend. [properties]: Add package updater helpers updater-extra-inputs, updater-extra-native-inputs. Change-Id: I3a152e6c66d27c912e18e67c114672397426e6e3
-rw-r--r--gnu/packages/python-crypto.scm26
1 files changed, 11 insertions, 15 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 4b75ba3b80..571a7ca7ed 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -615,14 +615,14 @@ ciphers, message digests and key derivation functions.")
(define-public python-pyopenssl
(package
(name "python-pyopenssl")
- (version "23.2.0")
+ (version "24.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyOpenSSL" version))
(sha256
(base32
- "1b4bkcpzhmablf592g21rq3l8apbhklp6wcwlvgfflm4algr6vr7"))))
+ "0vqsyji1q4vhd5yxlzks0z6va62knq64mxhfdjhz3yaxmazx9gna"))))
(build-system python-build-system)
(arguments
(list
@@ -634,25 +634,21 @@ ciphers, message digests and key derivation functions.")
;; PyOpenSSL runs tests against a certificate with a fixed
;; expiry time. To ensure successful builds in the future,
;; set the time to roughly the release date.
- (invoke "faketime" "2023-03-25" "pytest" "-vv" "-k"
- (string-append
- ;; This test tries to look up certificates from
- ;; the compiled-in default path in OpenSSL, which
- ;; does not exist in the build environment.
- "not test_fallback_default_verify_paths "
- ;; This test attempts to make a connection to
- ;; an external web service.
- "and not test_set_default_verify_paths "
- ;; Fails on i686-linux and possibly other 32-bit platforms
- ;; https://github.com/pyca/pyopenssl/issues/974
- "and not test_verify_with_time"))))))))
+ (invoke "faketime" "2024-03-09" "pytest" "-vv" "-k"
+ ;; This test tries to look up certificates from
+ ;; the compiled-in default path in OpenSSL, which
+ ;; does not exist in the build environment.
+ "not test_fallback_default_verify_paths ")))))))
(propagated-inputs (list python-cryptography))
(inputs (list openssl))
- (native-inputs (list libfaketime python-flaky python-pretend python-pytest))
+ (native-inputs (list libfaketime python-pretend python-pytest
+ python-pytest-rerunfailures))
(home-page "https://github.com/pyca/pyopenssl")
(synopsis "Python wrapper module around the OpenSSL library")
(description "PyOpenSSL is a high-level wrapper around a subset of the
OpenSSL library.")
+ (properties `((updater-extra-inputs . ("openssl"))
+ (updater-extra-native-inputs . ("libfaketime"))))
(license license:asl2.0)))
(define-public python-ed25519