summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-11 12:22:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-18 16:25:05 +0200
commit3cfdcbff4ab14d63a66b982237184766680590ba (patch)
treebac4ae08ea4d3d7953bb1741baca2c14cbe9ce60
parentc0a98fd3d167a692685c655a9305390a71021068 (diff)
gnu: texlive-bin: Skip building axodraw2.
* gnu/packages/tex.scm (texlive-bin)[arguments]<#:configure-flags>: Disable axodraw2 build. * gnu/packages/tex.scm (texlive-axodraw2): Remove now obsolete comment. Change-Id: Ie5b55fcaeb7f53a02766f60d730d6314fc128f5f
-rw-r--r--gnu/packages/tex.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc9f5c32e4..e86316b568 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -701,12 +701,9 @@ and should be preferred to it whenever a package would otherwise depend on
"--disable-mfluajit")
'())
;; Disable tools built in other packages.
- "--disable-chktex"
- "--disable-dvisvgm"
- "--disable-kpathsea"
- "--disable-psutils"
- "--disable-upmendex"
- "--disable-xindy"))
+ #$@(map (lambda (p) (string-append "--disable-" p))
+ '("axodraw2" "chktex" "dvisvgm" "kpathsea" "psutils"
+ "upmendex" "xindy"))))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'locate-external-kpathsea
@@ -4086,8 +4083,6 @@ other parts.")
#:tests? #true
#:phases
#~(modify-phases %standard-phases
- ;; TODO: Since we're building "axohelp" from source here, it can be
- ;; removed from `texlive-bin' (world rebuild).
(add-after 'unpack 'build-axohelp
(lambda* (#:key tests? #:allow-other-keys)
(with-directory-excursion "source/latex/axodraw2"