summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-12 18:43:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-18 16:25:12 +0200
commit8c71c04c3f4a9304ab43154c980666a645b95994 (patch)
tree9ed461ec846c3d8f7eeb030877fcffc043589228
parentd034480c7ba8f955f9e4a5fb4a7158c9b1d2606c (diff)
gnu: texlive-dvipdfmx: Build executables.
* gnu/packages/tex.scm (texlive-dvipdfmx-bin): New variable. (texlive-dvipdfmx)[arguments]<#:phases>: Include executables. [native-inputs]: Add TEXLIVE-DVIPDFMX-BIN. Change-Id: Ic10c4f74505689c1e1ba59103c7811de922362dc
-rw-r--r--gnu/packages/tex.scm50
1 files changed, 49 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d647f2c006..b4bcce3b8e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -38856,6 +38856,47 @@ running the script, you should have a working font installation in your local
TeX tree.")
(license license:lppl)))
+(define texlive-dvipdfmx-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-dvipdfmx-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '())
+ (delete-other-directories "texk" '("dvipdfm-x"))))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons* "--disable-all-pkgs"
+ "--enable-dvipdfm-x"
+ (delete "--disable-dvipdfm-x" #$flags)))
+ ((#:phases _)
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "texk/dvipdfm-x"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/dvipdfm-x"
+ (invoke "make" "install"))))))))
+ (inputs (list libpaper libpng))))
+
(define-public texlive-dvipdfmx
(package
(name "texlive-dvipdfmx")
@@ -38890,7 +38931,14 @@ TeX tree.")
(add-after 'unpack 'delete-map-file
;; This map file is supposed to be generated in a profile hook.
(lambda _
- (delete-file "fonts/map/dvipdfmx/updmap/kanjix.map"))))))
+ (delete-file "fonts/map/dvipdfmx/updmap/kanjix.map")))
+ (add-after 'install 'install-bin
+ (lambda _
+ (let ((source
+ #$(this-package-native-input "texlive-dvipdfmx-bin")))
+ (copy-recursively (string-append source "/bin")
+ (string-append #$output "/bin"))))))))
+ (native-inputs (list texlive-dvipdfmx-bin))
(propagated-inputs (list texlive-glyphlist))
(home-page "https://ctan.org/pkg/dvipdfmx")
(synopsis "Extended version of dvipdfm")