summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-01-17 21:42:12 +0100
committerAndreas Enge <andreas@enge.fr>2013-01-17 23:12:22 +0100
commit4b5f8cde38aaca91a41e694d2c967dbb7c7921fb (patch)
treef9c4e9d00b63369c59987246a26dcd3d957c9b2e
parentdd9e87e18556a7356ec299af5c2115c31e89ca11 (diff)
distro: Add Libjpeg.
* distro/packages/libjpeg.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--distro/packages/libjpeg.scm45
2 files changed, 46 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 745d8478cd..a7af1bae69 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,6 +82,7 @@ MODULES = \
distro/packages/less.scm \
distro/packages/libffi.scm \
distro/packages/libidn.scm \
+ distro/packages/libjpeg.scm \
distro/packages/libsigsegv.scm \
distro/packages/libunistring.scm \
distro/packages/libusb.scm \
diff --git a/distro/packages/libjpeg.scm b/distro/packages/libjpeg.scm
new file mode 100644
index 0000000000..5add26f2a8
--- /dev/null
+++ b/distro/packages/libjpeg.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages libjpeg)
+ #:use-module (distro)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public libjpeg
+ (package
+ (name "libjpeg")
+ (version "9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
+ version ".tar.gz"))
+ (sha256 (base32
+ "0dg5wxcx3cw0hal9gvivj97vid9z0s5sb1yvg55hpxmafn9rxqn4"))))
+ (build-system gnu-build-system)
+ (synopsis "Libjpeg, a library for handling JPEG files")
+ (description
+ "Libjpeg implements JPEG image encoding, decoding, and transcoding.
+JPEG is a standardized compression method for full-color and gray-scale
+images.
+The included programs provide conversion between the JPEG format and
+image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
+ (license ijg)
+ (home-page "http://www.ijg.org/")))