summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-01-17 22:09:15 +0100
committerAndreas Enge <andreas@enge.fr>2013-01-17 23:15:21 +0100
commitf24996724c6df5c6690e6e9a81aafc083989f853 (patch)
tree9c2a90fb90c50e85e82c0b9d6e0d71130677210e
parent4b5f8cde38aaca91a41e694d2c967dbb7c7921fb (diff)
distro: Add file.
* distro/packages/file.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am2
-rw-r--r--distro/packages/file.scm44
2 files changed, 46 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a7af1bae69..874dc1b6f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2013 Andreas Enge <andreas@enge.fr>
#
# This file is part of GNU Guix.
#
@@ -63,6 +64,7 @@ MODULES = \
distro/packages/ddrescue.scm \
distro/packages/ed.scm \
distro/packages/emacs.scm \
+ distro/packages/file.scm \
distro/packages/flex.scm \
distro/packages/gawk.scm \
distro/packages/gdb.scm \
diff --git a/distro/packages/file.scm b/distro/packages/file.scm
new file mode 100644
index 0000000000..61bdd71cfe
--- /dev/null
+++ b/distro/packages/file.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages file)
+ #:use-module (distro)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public file
+ (package
+ (name "file")
+ (version "5.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "08ix4xrvan0k80n0l5lqfmc4azjv5lyhvhwdxny4r09j5smhv78r"))))
+ (build-system gnu-build-system)
+ (synopsis "file, a file type guesser")
+ (description
+ "The file command is a file type guesser, a command-line tool that tells
+you in words what kind of data a file contains. It does not rely on filename
+extentions to tell you the type of a file, but looks at the actual contents
+of the file.")
+ (license bsd-2)
+ (home-page "http://www.darwinsys.com/file/")))