summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-05-19 11:01:40 +0300
committerAlex Kost <alezost@gmail.com>2016-05-24 11:11:26 +0300
commit486f36eb9eee508589c6edc99f4e194e105cc1ff (patch)
treedb886c53bbfbb59d0f1c60f89953af9a255d7f37
parentd16479c51e45276f719c3b11a243f7edf44d91ff (diff)
gnu: emacs: Remove *.elc and autoloads from the tarball.
* gnu/packages/emacs.scm (emacs)[source]: Add 'snippet' to remove compiled and generated elisp files.
-rw-r--r--gnu/packages/emacs.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 18898e9c29..ae02a079b0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -80,7 +80,18 @@
(base32
"0kn3rzm91qiswi0cql89kbv6mqn27rwsyjfb8xmwy9m5s8fxfiyx"))
(patches (search-patches "emacs-exec-path.patch"
- "emacs-source-date-epoch.patch"))))
+ "emacs-source-date-epoch.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Delete the bundled byte-compiled elisp files and
+ ;; generated autoloads.
+ '(with-directory-excursion "lisp"
+ (for-each delete-file
+ (append (find-files "." "\\.elc$")
+ (find-files "." "loaddefs\\.el$")
+ ;; This is the only "autoloads" file that
+ ;; does not have "*loaddefs.el" name.
+ '("eshell/esh-groups.el")))))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:phases