summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-09 22:23:47 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-09 22:23:47 +0100
commit374a9a8520ae6e9995a3e02dcf92cad95f14c52b (patch)
treefc8b4df4500645ef0632708620198743c58231bc
parent09a8778f73c64c2c1542bfa8552e4f5c3121ef4d (diff)
gnu: Add perl-libwww.
* gnu/packages/web.scm (perl-libwww): New variable.
-rw-r--r--gnu/packages/web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f8d052600a..3243a07d2b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -390,3 +390,40 @@ from the environment can be converted to Unicode strings by calling
Encode::encode(locale => $bytes) and converted back again with
Encode::decode(locale => $string).")
(home-page "http://search.cpan.org/~gaas/Encode-Locale/")))
+
+(define-public perl-libwww
+ (package
+ (name "perl-libwww")
+ (version "6.05")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/G/GA/GAAS/libwww-perl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "08wgwyz7748pv5cyngxia0xl6nragfnhrp4p9s78xhgfyygpj9bv"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-encode-locale" ,perl-encode-locale)
+ ("perl-file-listing" ,perl-file-listing)
+ ("perl-html-parser" ,perl-html-parser)
+ ("perl-http-cookies" ,perl-http-cookies)
+ ("perl-http-date" ,perl-http-date)
+ ("perl-http-daemon" ,perl-http-daemon)
+ ("perl-http-message" ,perl-http-message)
+ ("perl-http-negotiate" ,perl-http-negotiate)
+ ("perl-lwp-mediatypes" ,perl-lwp-mediatypes)
+ ("perl-net-http" ,perl-net-http)
+ ("perl-uri" ,perl-uri)
+ ("perl-www-robotrules" ,perl-www-robotrules)))
+ (license (package-license perl))
+ (synopsis "Perl modules for the WWW")
+ (description
+ "The libwww-perl collection is a set of Perl modules which provides a
+simple and consistent application programming interface to the
+World-Wide Web. The main focus of the library is to provide classes
+and functions that allow you to write WWW clients. The library also
+contain modules that are of more general use and even classes that
+help you implement simple HTTP servers.")
+ (home-page "http://search.cpan.org/~gaas/libwww-perl/")))