summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <john@darrington.wattle.id.au>2014-11-14 23:28:55 +0100
committerJohn Darrington <jmd@gnu.org>2014-11-15 19:13:46 +0100
commita886404f6882f63af3481ed90f37d970917df62f (patch)
tree213f20339e12bc867b722e368aef4778bd485e90
parent2b1cee21ae7c75f536626c124dc5c67a60f0eaea (diff)
gnu: Add opus-tools
* gnu/packages/xiph.scm (opus-tools): New variable.
-rw-r--r--gnu/packages/xiph.scm38
1 files changed, 36 insertions, 2 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 88ad2c1456..77b732ba35 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -43,7 +43,8 @@
flac
libkate
vorbis-tools
- opus))
+ opus
+ opus-tools))
(define libogg
(package
@@ -308,4 +309,37 @@ but is also intended for storage and streaming applications. It is
standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
(license license:bsd-3)
- (home-page "http://www.opus-codec.org/")))
+ (home-page "http://www.opus-codec.org")))
+
+(define opus-tools
+ (package
+ (name "opus-tools")
+ (version "0.1.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.mozilla.org/pub/mozilla.org/opus/opus-tools-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fk4nknvl111k89j5yckmyrh6b2wvgyhrqfncp7rig3zikbkv1xi"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; The package developers misuse pkg-config such that it doesn't work
+ ;; when cross compiling. Therefore we avoid it completly and set the
+ ;; necessary flags ourselves.
+ `(#:configure-flags (list (string-append "CFLAGS=-I"
+ (assoc-ref %build-inputs "libogg")
+ "/include -I"
+ (assoc-ref %build-inputs "opus")
+ "/include/opus"))))
+ (inputs `(("libogg" ,libogg)
+ ("opus" ,opus)
+ ("flac" ,flac)))
+ (synopsis "Command line utilities to encode, inspect, and decode .opus
+files")
+ (description "Opus is a royalty-free, highly versatile audio codec.
+Opus-tools provide command line utilities for creating, inspecting and
+decoding .opus files")
+ (license license:bsd-3)
+ (home-page "http://www.opus-codec.org")))