summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-10 11:35:50 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-10 11:35:50 +0200
commit3a4de6b2d2fdb515c8186cbceab4259aab91cadf (patch)
tree7eaa4544ba397ce3493c26679ee2eafe76f8e448
parentcaaf1933a453e7f3f8d7444f2c97dac3f8a93e1c (diff)
gnu: Add missing quotes in phase names passed to 'modify-phases'.
This is a followup to f8503e2. * gnu/packages/gnome.scm (glib-networking): Add missing quotes before phase names passed to 'modify-phases'. (libsoup): Likewise. (gnome-terminal): Likewise. (colord): Likewise. (geoclue): Likewise. * gnu/packages/gtk.scm (at-spi2-core, at-spi2-atk): Likewise. * gnu/packages/haskell.scm (ghc-network): Likewise. * gnu/packages/imagemagick.scm (perl-image-magick): Likewise. * gnu/packages/video.scm (aalib): Likewise. * gnu/packages/web.scm (nginx): Likewise.
-rw-r--r--gnu/packages/gnome.scm14
-rw-r--r--gnu/packages/gtk.scm4
-rw-r--r--gnu/packages/haskell.scm2
-rw-r--r--gnu/packages/imagemagick.scm6
-rw-r--r--gnu/packages/video.scm2
-rw-r--r--gnu/packages/web.scm6
6 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 356cfe0999..55a4978480 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1654,7 +1654,7 @@ library.")
'("--with-ca-certificates=no")
#:phases
(modify-phases %standard-phases
- (add-before configure patch-giomoduledir
+ (add-before 'configure 'patch-giomoduledir
;; Install GIO modules into $out/lib/gio/modules.
(lambda _
(substitute* "configure"
@@ -1702,14 +1702,14 @@ library.")
"/lib/gio/modules"))
#:phases
(modify-phases %standard-phases
- (add-before configure disable-unconnected-socket-test
+ (add-before 'configure 'disable-unconnected-socket-test
;; This test fails due to missing /etc/nsswitch.conf
;; in the build environment.
(lambda _
(substitute* "tests/socket-test.c"
((".*/sockets/unconnected.*") ""))
#t))
- (add-before check unset-LC_ALL
+ (add-before 'check 'unset-LC_ALL
;; The 'check-local' target runs 'env LANG=C sort -u',
;; unset 'LC_ALL' to make 'LANG' working.
(lambda _
@@ -1852,7 +1852,7 @@ floating in an ocean using only your brain and a little bit of luck.")
"--without-nautilus-extension")
#:phases
(modify-phases %standard-phases
- (add-before configure patch-/bin/true
+ (add-before 'configure 'patch-/bin/true
(lambda _
(substitute* "configure"
(("/bin/true") (which "true"))))))))
@@ -1913,14 +1913,14 @@ keyboard shortcuts.")
"/lib/udev/rules.d"))
#:phases
(modify-phases %standard-phases
- (add-before configure patch-/bin/true
+ (add-before 'configure 'patch-/bin/true
(lambda _
(substitute* "configure"
(("/bin/true") (which "true")))
(substitute* "src/Makefile.in"
(("if test -w \\$\\(DESTDIR\\)\\$\\(prefix\\)/;")
"if test -w $(DESTDIR)$(localstatedir);"))))
- (add-before build set-cc
+ (add-before 'build 'set-cc
(lambda _
;; Set $CC so that g-ir-scanner works.
(setenv "CC" "gcc")
@@ -1971,7 +1971,7 @@ output devices.")
"--with-dbus-service-user=geoclue")
#:phases
(modify-phases %standard-phases
- (add-before configure patch-/bin/true
+ (add-before 'configure 'patch-/bin/true
(lambda _
(substitute* "configure"
(("/bin/true") (which "true"))))))))
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index bb30f6f8fa..cd36ebfd65 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -359,7 +359,7 @@ in the GNOME project.")
"/share/gtk-doc/html"))
#:phases
(modify-phases %standard-phases
- (replace check
+ (replace 'check
;; Run test-suite under a dbus session.
(lambda _
(zero? (system* "dbus-launch" "make" "check")))))))
@@ -397,7 +397,7 @@ is part of the GNOME accessibility project.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (replace check
+ (replace 'check
;; Run test-suite under a dbus session.
(lambda _
(zero? (system* "dbus-launch" "make" "check")))))))
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f5f5020197..82c7109316 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -798,7 +798,7 @@ mutable and immutable), with a powerful loop optimisation framework.")
`(#:tests? #f ; FIXME: currently missing libraries used for tests.
#:phases
(modify-phases %standard-phases
- (add-before configure set-sh
+ (add-before 'configure 'set-sh
(lambda _ (setenv "CONFIG_SHELL" "sh"))))))
(home-page "https://github.com/haskell/network")
(synopsis "Low-level networking interface")
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 2a68627dc6..ab663b5a41 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
@@ -112,7 +112,7 @@ text, lines, polygons, ellipses and Bézier curves.")
`(#:phases
(modify-phases %standard-phases
(add-before
- configure image-magick-flags
+ 'configure 'image-magick-flags
(lambda* (#:key inputs #:allow-other-keys)
(let ((im (assoc-ref inputs "imagemagick")))
(substitute* "Makefile.PL"
@@ -121,7 +121,7 @@ text, lines, polygons, ellipses and Bézier curves.")
(("my \\$LIBS_magick = .*")
"my $LIBS_magick = `pkg-config --libs ImageMagick`;\n")))))
(add-before
- check skip-mpeg-tests
+ 'check 'skip-mpeg-tests
(lambda _
;; TODO: MPEG tests fail even though our imagemagick supports
;; MPEG. Has been reported elsewhere,
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 661ef91386..16c9770f45 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -97,7 +97,7 @@
(arguments
'(#:phases
(modify-phases %standard-phases
- (replace configure
+ (replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
;; This old `configure' script doesn't support
;; variables passed as arguments.
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 374642862a..c6a3938546 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -109,11 +109,11 @@ and its related documentation.")
`(#:tests? #f ; no test target
#:phases
(modify-phases %standard-phases
- (add-before configure patch-/bin/sh
+ (add-before 'configure 'patch-/bin/sh
(lambda _
(substitute* "auto/feature"
(("/bin/sh") (which "bash")))))
- (replace configure
+ (replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((flags
(list (string-append "--prefix=" (assoc-ref outputs "out"))
@@ -138,7 +138,7 @@ and its related documentation.")
(format #t "environment variable `CC' set to `gcc'~%")
(format #t "configure flags: ~s~%" flags)
(zero? (apply system* "./configure" flags)))))
- (add-after install fix-root-dirs
+ (add-after 'install 'fix-root-dirs
(lambda* (#:key outputs #:allow-other-keys)
;; 'make install' puts things in strange places, so we need to
;; clean it up ourselves.