summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-02-11 19:17:33 +0100
committerAndreas Enge <andreas@enge.fr>2014-02-11 19:44:48 +0100
commitb6b29c7737147bf683eb61bdbc93ad712a228ca7 (patch)
treeb3e9feaa3937a5f3b6f1ede7959fa3e9a509b56c
parent1680df13a8449c38fa8ac0b31903c4bfaf6f6fde (diff)
gnu: curl, gnurl: Fix failing testcase 172.
* gnu/packages/patches/curl-fix-test172.patch: New file. * gnu-system.am (dist_patch_DATA): Add the patch file. * gnu/packages/gnunet.scm (gnurl): Apply the patch file. * gnu/packages/curl.scm (curl): Apply the patch file. Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/curl.scm7
-rw-r--r--gnu/packages/gnunet.scm5
-rw-r--r--gnu/packages/patches/curl-fix-test172.patch12
4 files changed, 23 insertions, 2 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 3e9108cd87..8229cf0cdd 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -242,6 +242,7 @@ dist_patch_DATA = \
gnu/packages/patches/cdparanoia-fpic.patch \
gnu/packages/patches/cmake-fix-tests.patch \
gnu/packages/patches/cpio-gets-undeclared.patch \
+ gnu/packages/patches/curl-fix-test172.patch \
gnu/packages/patches/dbus-localstatedir.patch \
gnu/packages/patches/diffutils-gets-undeclared.patch \
gnu/packages/patches/dmd-getpw.patch \
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 7072ed3878..a9bfa76aa0 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -22,6 +22,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages gnutls)
#:use-module (gnu packages groff)
@@ -42,7 +43,11 @@
version ".tar.lzma"))
(sha256
(base32
- "13bhfs41yf60ys2hrikqxjwfzaj0gm91kqzsgc5fr4grzmpm38nx"))))
+ "13bhfs41yf60ys2hrikqxjwfzaj0gm91kqzsgc5fr4grzmpm38nx"))
+ (patches
+ ;; This patch fixes testcase 172 which uses a hardcoded cookie
+ ;; expiration value which is expired as of Feb 1, 2014.
+ (list (search-patch "curl-fix-test172.patch")))))
(build-system gnu-build-system)
(inputs `(("gnutls" ,gnutls)
("gss" ,gss)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 1529f96283..f3448a7e63 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -144,7 +144,10 @@ and support for SSL3 and TLS.")
version ".tar.bz2"))
(sha256
(base32
- "0kpi9wx9lg938b982smjg54acdwswdshs2bzf10sj5r6zmb05ygp"))))
+ "0kpi9wx9lg938b982smjg54acdwswdshs2bzf10sj5r6zmb05ygp"))
+ ;; This patch fixes testcase 172 which uses a hardcoded cookie
+ ;; expiration value which is expired as of Feb 1, 2014.
+ (patches (list (search-patch "curl-fix-test172.patch")))))
(build-system gnu-build-system)
(inputs `(("gnutls" ,gnutls)
("libidn" ,libidn)
diff --git a/gnu/packages/patches/curl-fix-test172.patch b/gnu/packages/patches/curl-fix-test172.patch
new file mode 100644
index 0000000000..cc2c2705e7
--- /dev/null
+++ b/gnu/packages/patches/curl-fix-test172.patch
@@ -0,0 +1,12 @@
+diff --git a/tests/data/test172 b/tests/data/test172
+index b3efae9..3d53418 100644
+--- a/tests/data/test172
++++ b/tests/data/test172
+@@ -36,7 +36,7 @@ http://%HOSTIP:%HTTPPORT/we/want/172 -b log/jar172.txt -b "tool=curl; name=fool"
+
+ .%HOSTIP TRUE /silly/ FALSE 0 ismatch this
+ .%HOSTIP TRUE / FALSE 0 partmatch present
+-%HOSTIP FALSE /we/want/ FALSE 1391252187 nodomain value
++%HOSTIP FALSE /we/want/ FALSE 2139150993 nodomain value
+ </file>
+ </client>