summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 13:07:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:13 +0200
commit42744c1db68f60ee76da27fdef0e1b57c0032207 (patch)
tree63046f00c0c6d871960d7514ccfeb20d062b2fbe
parentcfac79ba6b62bd2571f5db6493b2ed58f323f4d6 (diff)
gnu: Add ghc-chart.
* gnu/packages/haskell.scm (ghc-chart): New variable.
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0ae9799083..7347c87534 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9995,4 +9995,32 @@ for signal declarations that are used to call back from C to Haskell. These
tools are not needed to actually run Gtk2Hs programs.")
(license license:gpl2)))
+(define-public ghc-chart
+ (package
+ (name "ghc-chart")
+ (version "1.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/Chart/"
+ "Chart-" version ".tar.gz"))
+ (sha256
+ (base32
+ "13s64fhb2pmkdmx5bkgbgcn25qjihs364fvr47a1dw25f804kiy1"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-lens" ,ghc-lens)
+ ("ghc-colour" ,ghc-colour)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-operational" ,ghc-operational)
+ ("ghc-vector" ,ghc-vector)))
+ (home-page "https://github.com/timbod7/haskell-chart/wiki")
+ (synopsis "Library for generating 2D charts and plots")
+ (description
+ "This package provides a library for generating 2D charts and plots, with
+backends provided by the @code{Cairo} and @code{Diagrams} libraries.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here