summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 16:32:36 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-16 17:57:48 +0200
commit4505369c4ebbd8deaf401ec540927ea032538e5e (patch)
tree1af7aad0417e17a6563372fc0479e03d62730812
parent037d1851116fed5e9bf901abe923bff49078e2dd (diff)
gnu: libnfsidmap: Update to 0.27.
* gnu/packages/linux.scm (libnfsidmap): Update to 0.27. [source]: Update source URI. [native-inputs]: Add autoconf.
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 464b7a8427..cdee1f6001 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3778,25 +3778,25 @@ native Linux file system, and has been part of the Linux kernel since version
(define-public libnfsidmap
(package
(name "libnfsidmap")
- (version "0.25")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.citi.umich.edu/projects/nfsv4/linux/"
- name "/" name "-" version ".tar.gz"))
- (sha256
- (base32
- "1kzgwxzh83qi97rblcm9qj80cdvnv8kml2plz0q103j0hifj8vb5"))))
+ (version "0.27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://fedorapeople.org/~steved/"
+ name "/" version "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "0bg2bcii424mf1bnp3fssr8jszbvhdxl7wvifm1yf6g596v8b8i5"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list
(string-append "--with-pluginpath="
(assoc-ref %outputs "out")
"/lib/libnfsidmap"))))
+ (native-inputs
+ `(("autoconf" ,autoconf))) ; 0.27 still needs autoheader
(home-page
"http://www.citi.umich.edu/projects/nfsv4/crossrealm/libnfsidmap_config.html")
- (synopsis
- "NFSv4 support library for name/ID mapping")
+ (synopsis "NFSv4 support library for name/ID mapping")
(description "Libnfsidmap is a library holding mulitiple methods of
mapping names to ids and visa versa, mainly for NFSv4. It provides an
extensible array of mapping functions, currently consisting of two choices: