summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-29 22:46:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-29 22:46:58 +0200
commit0c82f6ad0ef92a5ee4b181ab9033dd3aaf2813e7 (patch)
treefd1836e334d6935061f569660045a355565c2c2c
parent57fa9cd8206ffb2afefd5fb66326cfdc7c156714 (diff)
gnu: cdogs-sdl: Update to 0.8.0.
* gnu/packages/games.scm (cdogs-sdl): Update to 0.8.0. [native-inputs]: Add `pkg-config'. [inputs]: Add `gtk+'.
-rw-r--r--gnu/packages/games.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1c27561834..210cf8ab58 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4819,24 +4819,27 @@ emerges from a sewer hole and pulls her below ground.")
(define-public cdogs-sdl
(package
(name "cdogs-sdl")
- (version "0.6.9")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cxong/cdogs-sdl.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "13gyv2hzk43za1n3lsjnd5v64xlzfzq7n10scd1rcbsnk1n007zr"))))
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cxong/cdogs-sdl.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vx37zb2iw7sfw5a2bs97ydlmb301nvy485ybdm8g46c5hn9s13c"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
(list (string-append "-DCDOGS_DATA_DIR="
(assoc-ref %outputs "out")
"/share/cdogs-sdl/"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
- `(("mesa" ,mesa)
+ `(("gtk+" ,gtk+)
+ ("mesa" ,mesa)
("sdl2" ,sdl2)
("sdl2-image" ,sdl2-image)
("sdl2-mixer" ,sdl2-mixer)))