summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-10 13:57:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-18 00:19:56 +0100
commit0e540ac1e204ccdb0f57958ea894b012f9bdcfb9 (patch)
tree833be53cfde8953fb5ca22ed730fc8bbd5491964
parent3993a28a36593187dde94c88b55d75ce12175fa7 (diff)
gnu: Switch from dri3proto to xorgproto.
* gnu/packages/gl.scm (mesa)[inputs]: Remove DRI3PROTO. * gnu/packages/xorg.scm (xorg-server)[propagated-inputs]: Likewise. (dri3proto)[properties]: Mark as superseded by XORGPROTO.
-rw-r--r--gnu/packages/gl.scm1
-rw-r--r--gnu/packages/xorg.scm6
2 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 920cc92655..daec4b52bc 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -251,7 +251,6 @@ also known as DXTn or DXTC) for Mesa.")
("xorgproto" ,xorgproto)))
(inputs
`(("expat" ,expat)
- ("dri3proto" ,dri3proto)
("libelf" ,libelf) ;required for r600 when using llvm
("libva" ,(force libva-without-mesa))
("libxml2" ,libxml2)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 4df95a1fb4..e412a949d9 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -372,7 +372,8 @@ translate between direct rendered buffers and X pixmaps. When combined with
the Present extension, a complete direct rendering solution for OpenGL is
provided.")
(license (license:x11-style "file://dri3proto.h"
- "See 'dri3proto.h' in the distribution."))))
+ "See 'dri3proto.h' in the distribution."))
+ (properties `((superseded . ,xorgproto)))))
(define-public %app-defaults-dir "/lib/X11/app-defaults")
@@ -5095,8 +5096,7 @@ over Xlib, including:
(file-name "xorg-server-use-intel-only-on-pre-gen4.diff"))))))
(build-system gnu-build-system)
(propagated-inputs
- `(("dri3proto" ,dri3proto)
- ("libpciaccess" ,libpciaccess)
+ `(("libpciaccess" ,libpciaccess)
("mesa" ,mesa)
("pixman" ,pixman)
("presentproto" ,presentproto)