summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-09-10 19:56:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-10 19:56:48 +0200
commit10792866a06bea44616f7580209ddad3bba30bf9 (patch)
tree98d57426516eef6008adba9871d55aafb20456a1
parent66b90d11840ac6c811931a10b339839ecc881689 (diff)
gnu: powertabeditor: Update to 2.0.0-alpha13.
* gnu/packages/music.scm (powertabeditor): Update to 2.0.0-alpha13.
-rw-r--r--gnu/packages/music.scm74
1 files changed, 35 insertions, 39 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6900037320..9ab5a19b6b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1410,46 +1410,42 @@ your own lessons.")
(license license:gpl3+)))
(define-public powertabeditor
- ;; This commit is after the switch from catch2 to doctest; I couldn't build
- ;; powertabeditor with catch2.
- (let ((commit "c5d39b25b75bf87ec693a3ac5018823b1d87f277")
- (revision "1"))
- (package
- (name "powertabeditor")
- (version (git-version "2.0.0-alpha12" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/powertab/powertabeditor")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "16qhqfvk14bp7s8cwr8ds8zfd80pq603d7aymr7967pnb49kic5z"))))
- (build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check (lambda _ (invoke "bin/pte_tests"))))))
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("boost" ,boost)
- ("minizip" ,minizip)
- ("pugixml" ,pugixml)
- ("qtbase" ,qtbase)
- ("rapidjson" ,rapidjson)
- ("rtmidi" ,rtmidi)
- ("timidity" ,timidity++)
- ("zlib" ,zlib)))
- (native-inputs
- `(("doctest" ,doctest)
- ("pkg-config" ,pkg-config)))
- (home-page "https://github.com/powertab/powertabedito")
- (synopsis "Guitar tablature editor")
- (description
- "Power Tab Editor 2.0 is the successor to the famous original Power Tab
+ (package
+ (name "powertabeditor")
+ (version "2.0.0-alpha13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/powertab/powertabeditor")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12il5xzgg53ick5k4ivvvqdagld5pgigiiz6s829kkdaymqr7vx5"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check (lambda _ (invoke "bin/pte_tests"))))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("boost" ,boost)
+ ("minizip" ,minizip)
+ ("pugixml" ,pugixml)
+ ("qtbase" ,qtbase)
+ ("rapidjson" ,rapidjson)
+ ("rtmidi" ,rtmidi)
+ ("timidity" ,timidity++)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("doctest" ,doctest)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/powertab/powertabedito")
+ (synopsis "Guitar tablature editor")
+ (description
+ "Power Tab Editor 2.0 is the successor to the famous original Power Tab
Editor. It is compatible with Power Tab Editor 1.7 and Guitar Pro.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public jalv-select
(package