summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-28 19:21:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-10-30 21:33:00 +0100
commit21405e81e7bf4016c4e8ed385186a94e8955bef7 (patch)
tree49fc1d313e7156c7656c5d56fc8d9444b8629061
parent03f8011220baf59a0314018c8e564b29c0c2b8b9 (diff)
gnu: Add r-gh.
* gnu/packages/cran.scm (r-gh): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c92b41d140..5e9973a071 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6714,3 +6714,25 @@ files to an structured list. Users can manipulate this resulting list with
@code{lapply()} functions. This same structured list can be used to write
back to file after modifications.")
(license license:gpl3)))
+
+(define-public r-gh
+ (package
+ (name "r-gh")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "gh" version))
+ (sha256
+ (base32
+ "1llinfajb0g7006jd2w1hpskxpmkjhnqarcjb71r1qvsccb2ph7k"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-httr" ,r-httr)
+ ("r-ini" ,r-ini)
+ ("r-jsonlite" ,r-jsonlite)))
+ (home-page "https://github.com/r-lib/gh#readme")
+ (synopsis "Access the GitHub API via R")
+ (description
+ "This package provides a minimal R client to access the GitHub API.")
+ (license license:expat)))