summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@suse.cz>2015-03-11 21:56:33 +0100
committerTomáš Čech <sleep_walker@gnu.org>2015-03-14 22:56:58 +0100
commit2459141e4cbcf1c9fad463fae6dbf29648d28a54 (patch)
tree986bee3dba6654adc419391b57d2c55503ca01f3
parent1e74439973083a99b83f9cda92e9628f011081f1 (diff)
gnu: Add tig.
* gnu/packages/version-control.scm (tig): New variable.
-rw-r--r--gnu/packages/version-control.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c0cdb047e1..5af2905eaa 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages linux)
;; #:use-module (gnu packages gnutls)
#:use-module (gnu packages nano)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages openssl)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -778,3 +779,28 @@ changes back into the master source of the program, with as little disruption
as possible. Resolution of contention for source files, a major headache for
any project with more than one developer, is one of Aegis's major functions.")
(license gpl3+)))
+
+(define-public tig
+ (package
+ (name "tig")
+ (version "2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://jonas.nitro.dk/tig/releases/tig-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1c1w6w39a1dwx4whrg0ga1mhrlz095hz875z7ajn6xgmhkv8fqih"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (arguments
+ `(#:tests? #f)) ; no tests implemented
+ (home-page "http://jonas.nitro.dk/tig/")
+ (synopsis "Ncurses-based text user interface for Git")
+ (description
+ "Tig is an ncurses text user interface for Git, primarily intended as
+a history browser. It can also stage hunks for commit, or colorize the
+output of the 'git' command.")
+ (license gpl2+)))