summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-25 15:51:12 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-27 21:02:56 +0200
commit29591fc4c48eac9f8b5010e22339b3ac3c947a90 (patch)
tree60d64642bcdbd2bbf7a542d5bfd7ddaec1bd81c1
parenta0604c2183a7db0f43032538c92cd5089e3bc686 (diff)
gnu: e2fsprogs: Update to 1.43.6.
* gnu/packages/linux.scm (e2fsprogs): Update to 1.43.6.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/linux.scm5
-rw-r--r--gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch46
3 files changed, 2 insertions, 50 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index bf03472519..e4c25bf12e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -588,7 +588,6 @@ dist_patch_DATA = \
%D%/packages/patches/doc++-segfault-fix.patch \
%D%/packages/patches/doxygen-test.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \
- %D%/packages/patches/e2fsprogs-32bit-quota-warnings.patch \
%D%/packages/patches/elfutils-tests-ptrace.patch \
%D%/packages/patches/elixir-disable-failing-tests.patch \
%D%/packages/patches/einstein-build.patch \
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 24278b440a..ae402ed34b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -693,17 +693,16 @@ slabtop, and skill.")
(define-public e2fsprogs
(package
(name "e2fsprogs")
- (version "1.43.5")
+ (version "1.43.6")
(source (origin
(method url-fetch)
(uri (string-append
"mirror://kernel.org/linux/kernel/people/tytso/"
name "/v" version "/"
name "-" version ".tar.xz"))
- (patches (search-patches "e2fsprogs-32bit-quota-warnings.patch"))
(sha256
(base32
- "05ssjpmy0fpv2ik6ibm1f47wr6794nf0q50r581vygrqvsd3s7r6"))))
+ "00ilv65dzcgiap435j89xk86shf7rrav3wsik7cahy789qijdcn9"))))
(build-system gnu-build-system)
(inputs `(("util-linux" ,util-linux)))
(native-inputs `(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch b/gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch
deleted file mode 100644
index e7a96a2ac0..0000000000
--- a/gnu/packages/patches/e2fsprogs-32bit-quota-warnings.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-Fix a test failure on 32-bit platforms.
-
-Patch copied from upstream source repository:
-
-https://git.kernel.org/pub/scm/fs/ext2/e2fsprogs.git/commit/?id=9e31a5696c4b699bf000a07b86601c1fb91c0493
-
-diff --git a/lib/support/mkquota.c b/lib/support/mkquota.c
-index 00f3a40..931a839 100644
---- a/lib/support/mkquota.c
-+++ b/lib/support/mkquota.c
-@@ -50,11 +50,13 @@ static void print_dquot(const char *desc, struct dquot *dq)
- {
- if (desc)
- fprintf(stderr, "%s: ", desc);
-- fprintf(stderr, "%u %ld:%ld:%ld %ld:%ld:%ld\n",
-- dq->dq_id, dq->dq_dqb.dqb_curspace,
-- dq->dq_dqb.dqb_bsoftlimit, dq->dq_dqb.dqb_bhardlimit,
-- dq->dq_dqb.dqb_curinodes,
-- dq->dq_dqb.dqb_isoftlimit, dq->dq_dqb.dqb_ihardlimit);
-+ fprintf(stderr, "%u %lld:%lld:%lld %lld:%lld:%lld\n",
-+ dq->dq_id, (long long) dq->dq_dqb.dqb_curspace,
-+ (long long) dq->dq_dqb.dqb_bsoftlimit,
-+ (long long) dq->dq_dqb.dqb_bhardlimit,
-+ (long long) dq->dq_dqb.dqb_curinodes,
-+ (long long) dq->dq_dqb.dqb_isoftlimit,
-+ (long long) dq->dq_dqb.dqb_ihardlimit);
- }
- #else
- static void print_dquot(const char *desc EXT2FS_ATTR((unused)),
-@@ -524,11 +526,11 @@ static int scan_dquots_callback(struct dquot *dquot, void *cb_data)
- dq->dq_dqb.dqb_curinodes != dquot->dq_dqb.dqb_curinodes) {
- scan_data->usage_is_inconsistent = 1;
- fprintf(stderr, "[QUOTA WARNING] Usage inconsistent for ID %u:"
-- "actual (%ld, %ld) != expected (%ld, %ld)\n",
-- dq->dq_id, dq->dq_dqb.dqb_curspace,
-- dq->dq_dqb.dqb_curinodes,
-- dquot->dq_dqb.dqb_curspace,
-- dquot->dq_dqb.dqb_curinodes);
-+ "actual (%lld, %lld) != expected (%lld, %lld)\n",
-+ dq->dq_id, (long long) dq->dq_dqb.dqb_curspace,
-+ (long long) dq->dq_dqb.dqb_curinodes,
-+ (long long) dquot->dq_dqb.dqb_curspace,
-+ (long long) dquot->dq_dqb.dqb_curinodes);
- }
-
- if (scan_data->update_limits) {