summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-14 14:17:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-14 16:31:46 +0200
commit2bfe99b11ac89ea723fd5d8aed9d6cdac78d71d4 (patch)
tree60aac6b25132626aeb6e3a2174bc4ffaaf7e21e6
parentea36db33924ec06450578d8febd6268e0ae439ba (diff)
gnu: cpuid: Use CC-FOR-TARGET.
This doesn't actually enable cross-compilation. * gnu/packages/linux.scm (cpuid)[arguments]: Use CC-FOR-TARGET.
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1c71c159db..93db178b47 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6437,7 +6437,8 @@ available in the kernel Linux.")
"19jnkh57f979b78ak5mpxmdvnkgc33r55cw9shgd2hc380b3zi8k"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags '("CC=gcc")
+ '(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target)))
#:tests? #f ; no tests
#:phases (modify-phases %standard-phases
(delete 'configure) ; no configure script