summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-28 19:22:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-10-30 21:34:35 +0100
commit319a80ce96f49e6750c80529dd5fbdf50594b343 (patch)
tree142b6fe0e58e26faccb5e5b95a7181ba00e789f6
parent9b02d1a11e75044d46e5341b47659d45b1ecb21f (diff)
gnu: Add r-pander.
* gnu/packages/cran.scm (r-pander): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab93c833f8..bed280ba51 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6934,3 +6934,29 @@ of the individual checks.")
advanced statistical methods with the advantage of having sane defaults for
quick reporting.")
(license license:agpl3+)))
+
+(define-public r-pander
+ (package
+ (name "r-pander")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pander" version))
+ (sha256
+ (base32
+ "0gd7rqkpbraznip8jmri9lqa8ajg1sryyplhd6m633wg91whiipi"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://rapporter.github.io/pander")
+ (synopsis "Render R objects into Pandoc's markdown")
+ (description
+ "The main aim of the pander R package is to provide a minimal and easy
+tool for rendering R objects into Pandoc's markdown. The package is also
+capable of exporting/converting complex Pandoc documents (reports) in various
+ways.")
+ ;; This package is licensed under either the AGPLv3+ or the very rarely
+ ;; used OSL 3.0.
+ (license license:agpl3+)))