summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Hashe <david.hashe@dhashe.com>2015-11-08 13:57:44 -0600
committer宋文武 <iyzsong@gmail.com>2015-11-09 14:42:50 +0800
commit329d731b966c8e222a0997ebd4babd5f9edff3de (patch)
treefa1be550b5965301f74b049599ed228cb6a47051
parent835ed74b3a4bcec041632b658ebf6863e0e7b597 (diff)
gnu: Add gedit.
* gnu/packages/gnome.scm (gedit): New variable. Co-authored-by: 宋文武 <iyzsong@gmail.com>
-rw-r--r--gnu/packages/gnome.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b584270ba8..cd6db9b664 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -45,6 +45,7 @@
#:use-module (gnu packages djvu)
#:use-module (gnu packages flex)
#:use-module (gnu packages docbook)
+ #:use-module (gnu packages enchant)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
@@ -3762,3 +3763,60 @@ configuration program to choose applications starting on login.")
"Gjs is a javascript binding for GNOME. It's mainly based on spidermonkey
javascript engine and the GObject introspection framework.")
(license license:gpl2+)))
+
+(define-public gedit
+ (package
+ (name "gedit")
+ (version "3.18.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1kb3hglcppap7fdy7i7w2wk746kfz77jzs2lq6vrna8a3fqaxmas"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'install 'wrap-gedit
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gtksourceview (assoc-ref inputs "gtksourceview"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (wrap-program (string-append out "/bin/gedit")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ ;; For language-specs.
+ `("XDG_DATA_DIRS" ":" prefix (,(string-append gtksourceview
+ "/share")))))
+ #t)))))
+ (propagated-inputs
+ `(("dconf" ,dconf)))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("itstool", itstool)
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gtksourceview" ,gtksourceview)
+ ("libpeas" ,libpeas)
+ ("libxml2" ,libxml2)
+ ("enchant" ,enchant)
+ ("iso-codes" ,iso-codes)
+ ("python-pygobject" ,python-pygobject)
+ ("python" ,python)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("libx11" ,libx11)
+ ("vala" ,vala)
+ ("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("libsoup" ,libsoup)
+ ("gnome-desktop" ,gnome-desktop)))
+ (home-page "https://wiki.gnome.org/Apps/Gedit")
+ (synopsis "GNOME text editor")
+ (description "While aiming at simplicity and ease of use, gedit is a
+powerful general purpose text editor.")
+ (license license:gpl2+)))