summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-16 23:50:49 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-17 01:40:14 +0200
commit3348e9f371da1ff7d73e09af28e150d0653568a5 (patch)
treea75a67ec6bb766036297887677fc5cafbfc56f36
parenta14de83213a8d4fe6befced5a3dcf05e40fe4513 (diff)
gnu: emacs-fish-completion: Don't propagate inputs.
* gnu/packages/emacs.scm (emacs-fish-completion)[propagated-inputs]: Remove fish [inputs]: Add fish. [arguments]: New field. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm55
1 files changed, 34 insertions, 21 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4999dda55b..88134ea4e7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10843,26 +10843,39 @@ Org-mode. It features:
(license license:gpl3+))))
(define-public emacs-fish-completion
- (package
- (name "emacs-fish-completion")
- (version "20180329")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/Ambrevar/emacs-fish-completion/archive/"
- "3e3ed1f19fa778b7c35ad88e033dce5a6b1fc153"
- ".tar.gz"))
- (sha256
- (base32
- "16329py7fvid0bap1qhqxhdc68m9qqy1p8gc2bhng81zhm5a5zsm"))))
- (build-system emacs-build-system)
- (propagated-inputs `(("fish" ,fish)))
- (home-page
- "https://github.com/Ambrevar/emacs-fish-completion")
- (synopsis "Fish completion for Emacs pcomplete")
- (description
- "This package provides completion for the Fish shell to pcomplete (used
+ (let ((commit "bac15fda1392a891070574dfe5d2d50b10831e8b"))
+ (package
+ (name "emacs-fish-completion")
+ (version (git-version "20180616" "1" commit))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gitlab.com/Ambrevar/emacs-fish-completion/repository/"
+ "archive.tar.gz?ref="
+ commit))
+ (sha256
+ (base32
+ "093qzdrbkl7dhjk16zq8i13kh1phyigkblcfrbgbrxjqd2ndrfdi"))))
+ (build-system emacs-build-system)
+ (inputs `(("fish" ,fish)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((fish (assoc-ref inputs "fish")))
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (emacs-substitute-variables
+ "fish-completion.el"
+ ("fish-completion-command"
+ (string-append fish "/bin/fish")))))))))
+ (home-page
+ "https://gitlab.com/Ambrevar/emacs-fish-completion")
+ (synopsis "Fish completion for Emacs pcomplete")
+ (description
+ "This package provides completion for the Fish shell to pcomplete (used
by shell and Eshell). You can set it up globally with:
@example
@@ -10877,7 +10890,7 @@ shell/Eshell mode hook.
The package @code{emacs-bash-completion} is an optional dependency: if available,
@code{fish-completion-complete} can be configured to fall back on bash to further
try completing. See @code{fish-completion-fallback-on-bash-p}.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-gif-screencast
(let ((commit "825e606950ec842304bf75cf85baef707b853b03"))