summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-11-02 16:01:19 -0400
committerLeo Famulari <leo@famulari.name>2017-11-02 16:03:25 -0400
commit3440f12a7ee65692c809a8fa867c25c317e1e4e6 (patch)
treef0fa2136a7cfd51ea3ef610e82d059247cbd45d8
parent13fbd174b5ffe5c2cc59e637f7859d357ab33d97 (diff)
gnu: mpv: enable Wayland support.
* gnu/packages/video.scm (mpv)[inputs]: Add wayland and libxkbcommon.
-rw-r--r--gnu/packages/video.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e66a30a824..504d5d30a2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1006,7 +1007,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
`(("perl" ,perl) ; for zsh completion file
("pkg-config" ,pkg-config)
("python-docutils" ,python-docutils)))
- ;; Missing features: libguess, Wayland, V4L2
+ ;; Missing features: libguess, V4L2
(inputs
`(("alsa-lib" ,alsa-lib)
("enca" ,enca)
@@ -1038,6 +1039,8 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
("pulseaudio" ,pulseaudio)
("rsound" ,rsound)
("waf" ,python-waf)
+ ("wayland" ,wayland)
+ ("libxkbcommon", libxkbcommon)
("youtube-dl" ,youtube-dl)
("zlib" ,zlib)))
(arguments