summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-09-02 15:35:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-02 16:46:37 +0200
commit35aa90a1fd4d8f29d0c88e4a73a7971cb261c68e (patch)
treedc1767be0e509be668291dc35773d3ad63146e8a
parentd058708e86dab50579d3147e3ee2c6fcc03e63c9 (diff)
gnu: Add Infernal.
* gnu/packages/bioinformatics.scm (infernal): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 08c25459c0..2d76a81339 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4835,6 +4835,32 @@ data in the form of VCF files.")
;; at https://vcftools.github.io/license.html
(license license:lgpl3)))
+(define-public infernal
+ (package
+ (name "infernal")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://eddylab.org/software/infernal/"
+ "infernal-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sr2hiz3qxfwqpz3whxr6n82p3x27336v3f34iqznp10hks2935c"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl))) ; for tests
+ (home-page "http://eddylab.org/infernal/")
+ (synopsis "Inference of RNA alignments")
+ (description "Infernal (\"INFERence of RNA ALignment\") is a tool for
+searching DNA sequence databases for RNA structure and sequence similarities.
+It is an implementation of a special case of profile stochastic context-free
+grammars called @dfn{covariance models} (CMs). A CM is like a sequence
+profile, but it scores a combination of sequence consensus and RNA secondary
+structure consensus, so in many cases, it is more capable of identifying RNA
+homologs that conserve their secondary structure more than their primary
+sequence.")
+ (license license:bsd-3)))
+
(define-public r-vegan
(package
(name "r-vegan")